Unable to choose both Nightly and Firefox from Control Panel defaults

RESOLVED DUPLICATE of bug 1324617

Status

()

defect
P2
normal
RESOLVED DUPLICATE of bug 1324617
6 years ago
2 years ago

People

(Reporter: manuela.muntean, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=0)

(Reporter)

Description

6 years ago
Tested with the latest Nightly (build ID: 20130918030202) and Firefox 24 release, on a Win 8 32bit machine

STR
1. Install both latest Nightly and Fx 24 release in the standard folder (Program Files)
2. Go to Control Panel -> Default Programs, and try to set them both to be the default browser, consecutively

Actual results: step 2 can't be performed, because in Control Panel -> Default Programs I can only see Nightly; Firefox 24 doesn't appear in that list. I can only make Firefox 24 to be the default browser if I open it and set it from the Tools -> Options -> Advanced menu

Another strange thing that happens here, is that if I make Fx 24 default browser as exaplained above, the Metro icon still remains visible in the Start Page, and if I enter it, it opens Nightly in desktop mode

Expected results: step 2 should be performed smoothly, without any issues
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0
This is not a Metro specific bug to the best of my knowledge.  Can you reproduce with Firefox and Beta builds (which don't have Metro Firefox) using the same steps?

All Firefox browser's use the same FirefoxURL app id key so I think you're just seeing that.

I have some ideas on how it could be fixed though
Flags: needinfo?(manuela.muntean)
Summary: Defect - unable to make Nightly or Firefox my default browser from Control Panel → Defect - Unable to choose both Nightly and Firefox from Control Panel defaults
(Reporter)

Comment 2

6 years ago
(In reply to Brian R. Bondy [:bbondy] from comment #1)
> This is not a Metro specific bug to the best of my knowledge.  Can you
> reproduce with Firefox and Beta builds (which don't have Metro Firefox)
> using the same steps?
> 
> All Firefox browser's use the same FirefoxURL app id key so I think you're
> just seeing that.
> 
> I have some ideas on how it could be fixed though

I've uninstalled everything related to Firefox, and then installed 24 ESR (in Program Files) and 25 beta 1 (on the Desktop, because if I would have chosen the standard folder to install in, it would have paved over the 24 ESR)

When going to Control Panel -> Default Programs, in the list, I can only see one Firefox, and I have to make it the default browser to see which one it is. It's 24 ESR, the one installed in the standard folder.
Flags: needinfo?(manuela.muntean)
Yep thanks for checking, this is how multi-installs have always worked.
Let's leave this open though because I think it may be able to be fixed without too much effort.
The fix here is to add an extra entry per channel in:
HKEY_CURRENT_USER\Software\RegisteredApplications

That new entry would point to another new entry you need to ad here:
HKEY_CURRENT_USER\Software\Clients\StartMenuInternet\${Channel}-FIREFOX.EXE

These references would need to be all updated:
http://dxr.mozilla.org/mozilla-central/search?tree=mozilla-central&q=StartMenuInternet&redirect=true

Then we'd need to test we don't break any default status via helper.exe /PostUpdate, but I don't think we would.
p=3 (but Firefox has always worked this way, not Metro specific)
tentatively blocking since it's a pain for testers.
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0 → [preview] feature=defect c=tbd u=tbd p=0
Whiteboard: [preview] feature=defect c=tbd u=tbd p=0 → feature=defect c=tbd u=tbd p=0
Whiteboard: feature=defect c=tbd u=tbd p=0 → [block28] feature=defect c=tbd u=tbd p=0

Updated

6 years ago
Blocks: 935467
I'm sure I'll regret this. :)
Assignee: nobody → ally

Updated

6 years ago
Duplicate of this bug: 942392
(In reply to Brian R. Bondy [:bbondy] from comment #4)
> The fix here is to add an extra entry per channel in:
> HKEY_CURRENT_USER\Software\RegisteredApplications
> 
> That new entry would point to another new entry you need to ad here:
> HKEY_CURRENT_USER\Software\Clients\StartMenuInternet\${Channel}-FIREFOX.EXE
> 
> These references would need to be all updated:
> http://dxr.mozilla.org/mozilla-central/search?tree=mozilla-
> central&q=StartMenuInternet&redirect=true
> 
> Then we'd need to test we don't break any default status via helper.exe
> /PostUpdate, but I don't think we would.

It is insufficient. We should stop Nightly finding an existing Firefox instance, and vice versa. Otherwise Nightly will not start if Firefox is already running. A new Firefox window will open instead.
This bug is really only about the registration though, to address something along the lines of multi profile per installation please post another bug.
Blocks: metrov1it20
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
Whiteboard: [block28] feature=defect c=tbd u=tbd p=0 → [block28] feature=defect c=tbd u=tbd p=5
Whiteboard: [block28] feature=defect c=tbd u=tbd p=5 → [release28] feature=defect c=tbd u=tbd p=5
I don't think there's any new strings here and this is only relating to multi installs, so marking as release28 instead of block28.
Blocks: metrov1it21
No longer blocks: metrov1it20
Whiteboard: [release28] feature=defect c=tbd u=tbd p=5 → [beta28] feature=defect c=tbd u=tbd p=5
I've tried to vet out bbondy's idea, but all I seem to have accomplished is screwing up my registry! I think his idea has merit, but there might be some catch or edge case I don't know enough about the registry to catch.
Assignee: ally → nobody
Status: ASSIGNED → NEW
Blocks: metrov1backlog
No longer blocks: metrov1it21
QA Contact: jbecerra
Whiteboard: [beta28] feature=defect c=tbd u=tbd p=5 → [beta28] p=0
(In reply to Brian R. Bondy [:bbondy] from comment #4)
> The fix here is to add an extra entry per channel in:
> HKEY_CURRENT_USER\Software\RegisteredApplications
> 
> That new entry would point to another new entry you need to ad here:
> HKEY_CURRENT_USER\Software\Clients\StartMenuInternet\${Channel}-FIREFOX.EXE
> 
> These references would need to be all updated:
> http://dxr.mozilla.org/mozilla-central/search?tree=mozilla-
> central&q=StartMenuInternet&redirect=true
> 
> Then we'd need to test we don't break any default status via helper.exe
> /PostUpdate, but I don't think we would.
I tried doing this way back when and I clearly recall Windows auto-creating registry keys that screwed this up which is why I went with FIREFOX.EXE. I don't recall if this was with Win9X, Win2K, or WinXP so this would need to be thoroughly tested on XP by checking for auto added registry keys.
No longer blocks: 935467
Summary: Defect - Unable to choose both Nightly and Firefox from Control Panel defaults → Unable to choose both Nightly and Firefox from Control Panel defaults
Whiteboard: [beta28] p=0 → [beta28] [defect] p=0
Whiteboard: [beta28] [defect] p=0 → [defect] p=0
Blocks: metrobacklog
No longer blocks: metrov1backlog
Whiteboard: [defect] p=0
Whiteboard: [defect] p=0
triage: booted from blocker list since we've declared multi-installs not blocking v1. I'd still like us to fix this in the future.
Priority: P2 → --

Updated

5 years ago
Blocks: 855311
Priority: -- → P2
Whiteboard: [defect] p=0 → p=0
Firefox for Metro is dead, but this bug is not Metro specific as already stated in this bug twice.
Component: Install/Update → Shell Integration
Product: Firefox for Metro → Firefox
Blocks: 1250870
The majority if not all of the work will need to be done in the installer so changing component.
Component: Shell Integration → Installer
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1324617
You need to log in before you can comment on or make changes to this bug.