"Edit message as new" displaying mojibake due to wrong charset override

RESOLVED DUPLICATE of bug 1239658

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 1239658
2 years ago
2 years ago

People

(Reporter: postaspam, Unassigned)

Tracking

Trunk
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8723547 [details]
Emails.zip

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160212012805

Steps to reproduce:

Import the two attached mails in Thunderbird (38.6.0), click on "ORDINE INTERNO 2 (rif. Cliente (Rivenditore))" to select it, press right mouse button on the other message "ORDINE INTERNO 1 (rif. Cliente (Rivenditore))" and on contextual menu select "Edit message as new" command.


Actual results:

The new email created starting from "ORDINE INTERNO 1 (rif. Cliente (Rivenditore))" contains strange characters.



Expected results:

The mail has to be the same as the original one.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
I cannot reproduce this at all. The e-mail you attached is 100% ASCII, there isn't a single accented character. There is not a chance any "strange characters" can be produced. Please supply a screenshot. Which version of TB are you using?

Subject: ORDINE INTERNO 1 (rif. Cliente (Rivenditore))
References: <51C7F83F.1000009@server>
In-Reply-To: <51C7F83F.1000009@server>
Content-Type: multipart/alternative;
 boundary="------------070102000400060802010802"

This is a multi-part message in MIME format.
--------------070102000400060802010802
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 7bit

Ordine:        num - 16/xx
Riferimento: Cliente (Rivenditore)
Versione:     16.x.x
Stato:          in fase di test
Stato:          pronto da masterizzare
Stato:          pronto



--------------070102000400060802010802
Content-Type: text/html; charset=utf-8
Content-Transfer-Encoding: 8bit

<html>
  <head>
    <meta http-equiv="content-type" content="text/html; charset=utf-8">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <font face="Tahoma">Ordine:        num - 16/xx<br>
      Riferimento: Cliente (Rivenditore)<br>
      Versione:     16.x.x<br>
      Stato:          in fase di test<br>
      Stato:          pronto da masterizzare<br>
      Stato:          pronto<br>
    </font><br>
    <br>
  </body>
</html>

--------------070102000400060802010802--
Summary: "Edit message as new" wrong coping data → "Edit message as new" displaying "strange" characters (mojibake?)
(Reporter)

Comment 2

2 years ago
Created attachment 8727437 [details]
Image1.png
(Reporter)

Comment 3

2 years ago
Created attachment 8727438 [details]
Image 2.png
(Reporter)

Comment 4

2 years ago
I attached the 2 requested images, Image 1 is correct, Image 2 is not.
The Thunderbird version where I found the issue is 38.6.0.

Thanks
OK, I've looked at it a little closer now. In ORDINE INTERNO num (rif. Cliente (Rivenditore)).eml you have a line
Stato:          in fase di test
Looking at this with the hex editor, you can see that the space consists of non-breaking spaces (UTF-8: C2A0) and normal spaces.

When I edit this message as new, it looks OK, I don't get what you're getting. But my "edit as new" uses UTF-8 encoding. You're edit as new somehow doesn't use UTF-8, you can see in your second image, that there is no UTF-8 in the title bar (compare to the first image).

If you interpret the two bytes C2A0 as ISO-8859-1, you get  followed by a non-breaking space. Look up C2 and A0 here: https://en.wikipedia.org/wiki/ISO/IEC_8859-1

Now the question is: Why do you get ISO-8859-1 encoding for a message that you edit as new and that is in UTF-8?

Do you always get the problem when you "edit as new"? I don't think so. You only get it when you "edit as new" without viewing the message first, am I right?

We had two bugs where you sometimes got the wrong charset: Bug 1239658 and bug 597369.

These bugs have been fixed and will be shipped with TB 45.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Summary: "Edit message as new" displaying "strange" characters (mojibake?) → "Edit message as new" displaying mojibake due to wrong charset override
Duplicate of bug: 1239658
(Reporter)

Comment 6

2 years ago
(In reply to Jorg K (GMT+1) from comment #5)
> Do you always get the problem when you "edit as new"? I don't think so.
No, I have not problem when I select the message and press the mouse right button over it.


> You only get it when you "edit as new" without viewing the message first, am I right?
Yes, you are right.


Thank you.
Thanks for the confirmation. As I said, two bugs in that area were fixed. The next release of TB 45 won't show the problem.
You need to log in before you can comment on or make changes to this bug.