Composer needs a Publish icon for main toolbar

VERIFIED FIXED in mozilla1.0.1

Status

SeaMonkey
Themes
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Charles Manske, Assigned: Charles Manske)

Tracking

({icon})

Trunk
mozilla1.0.1
x86
Windows 2000
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: publish, icon [adt2 RTM] [ETA 6/21])

Attachments

(3 attachments, 2 obsolete attachments)

(Assignee)

Description

16 years ago
We will be morphing the "Save" toolbar item into "Publish" when users are
editing a remote URL. This image needs to be in a similar style to current
Composer icons, but convey saving to a web or network location.
Icons needed for Modern and Classic themes.
(Assignee)

Updated

16 years ago
Blocks: 88208
Whiteboard: publish
(Assignee)

Comment 1

16 years ago
nominating for nsbeta1
Keywords: nsbeta1

Updated

16 years ago
Whiteboard: publish → publish, icon

Comment 2

16 years ago
*** Bug 125722 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
If the print button is going to morph into a publish button it might give the
impression to people who initially started with a local file that the publish
facility is not available (at a first glance anyway).
(Assignee)

Comment 4

16 years ago
Created attachment 69861 [details]
MODERN-Primary toolbar images including a Publish button

Just a 1st draft so we can display something!
Based on 4.7 publish icon.
(Assignee)

Comment 5

16 years ago
Created attachment 69862 [details]
CLASSIC-Primary toolbar buttons including Publish button

1st draft for Classic theme
(Assignee)

Comment 6

16 years ago
Created attachment 69864 [details] [diff] [review]
Composer themes css changes to use publish button
(Assignee)

Comment 7

16 years ago
Taking bug for themes patch and 1st draft of icons.
Assignee: marlon → cmanske
Keywords: nsbeta1 → nsbeta1+, patch, review
Whiteboard: publish, icon → publish, icon, FIX IN HAND, need r=.sr=
Target Milestone: --- → mozilla0.9.9
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Comment on attachment 69864 [details] [diff] [review]
Composer themes css changes to use publish button

r=glazman
Attachment #69864 - Flags: review+
(Assignee)

Updated

16 years ago
Whiteboard: publish, icon, FIX IN HAND, need r=.sr= → publish, icon, FIX IN HAND, need sr=
Comment on attachment 69864 [details] [diff] [review]
Composer themes css changes to use publish button

sr=dveditz
Attachment #69864 - Flags: superreview+
(Assignee)

Comment 10

16 years ago
Comment on attachment 69864 [details] [diff] [review]
Composer themes css changes to use publish button

checked in.
Attachment #69864 - Attachment is obsolete: true
(Assignee)

Comment 11

16 years ago
checked in. Handing back to Marlon for final versions of icons
Assignee: cmanske → marlon
Status: ASSIGNED → NEW
Keywords: patch, review
Whiteboard: publish, icon, FIX IN HAND, need sr= → publish, icon
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0

Updated

16 years ago
Keywords: icon

Comment 12

16 years ago
I'm not sure what the current status of this bug is. The icon appears to be
done. Marlon, can you comment so we can add the appropriate [adt] keyword to
this bug?
(Assignee)

Comment 13

16 years ago
You like that icon? I whipped it up by copying the old one from 4.x. Blended into
the new style, but I'm sure Marlon could improve upon it!
It wasn't intended to be the final version. 
Publishing is obviously very important to Composer, so it would be nice to have
a really good icon.

Comment 14

16 years ago
Please update this bug with an [adt1] - [adt3] impact rating (or take it off the
list if it doesn't even rate adt3.)  Thanks!
(Assignee)

Comment 15

16 years ago
Adding status whiteboard notation to be sure this gets ADT attention.
Since I've seen some good art for this, I know a good fix is pending!
Can we please get some samples attached here so we can evaluate them?
Whiteboard: publish, icon → publish, icon [adt2 RTM]

Updated

16 years ago
Blocks: 143047
Whiteboard: publish, icon [adt2 RTM] → publish, icon [adt2 RTM] [Need ETA] [Needs a=]

Comment 16

16 years ago
Created attachment 86722 [details]
the new publish button (4 states)

Comment 17

16 years ago
cc'ing docs and l10n as a change like this, after the UI freeze may effect their
schedules.
(Assignee)

Comment 18

16 years ago
Umm, we can certainly live with this icon, but this is "C" in the original
suggestions and Lori said version "B" was the one accepted. "B" had many more
votes because the page graphic was more consistent with the others on the 
toolbar. This one is ok, though and I'm not suggesting we change it, but I just 
wanted to be sure our review process was noted.

BTW, is the Classic theme version ready?

Comment 19

16 years ago
the review process was indeed noted, and i think that i took the votes for B
into consideration when deciding that C was the best variation.  C conveys the
'in-motion' aspect, where in B the document was 'dead' flat on a surface.  I
think that motion is important for the implied meaning behind the icon, wouldn't
you agree?
(Assignee)

Comment 20

16 years ago
Yes, I picked up on the "in motion" aspect of C, which is why I decided that it
is quite acceptable!

Updated

16 years ago
Whiteboard: publish, icon [adt2 RTM] [Need ETA] [Needs a=] → publish, icon [adt2 RTM] [Need ETA] [Needs L10N Approval]

Comment 21

16 years ago
Approved for UI change from L10N. 

Comment 22

16 years ago
Please check in the new publish icon. 
Assignee: marlon → cmanske
Whiteboard: publish, icon [adt2 RTM] [Need ETA] [Needs L10N Approval] → publish, icon [adt2 RTM] [ETA 6/20/02]
(Assignee)

Comment 23

16 years ago
The publishing icon is NOT a separate image, but is part of one large image in 
the themes somewhere. That integration really should be done by UE, but I'll
look into it.
The attached zip still does not have any images for Classic theme.
Status: NEW → ASSIGNED
(Assignee)

Comment 24

16 years ago
Ok, I found the toolbar image file thanks to Joe Hewitt, so I can integrate the 
images. 
Since it seems Classic simply looks like 4.x icons, the existing publishing 
images are ok, since that's where they were taken from.
(Assignee)

Comment 25

16 years ago
Created attachment 88403 [details]
New publish images integrated into themes toolbar graphic

This is the file that needs to be checked in to update Publish icons.
(Assignee)

Updated

16 years ago
Attachment #86722 - Attachment is obsolete: true
(Assignee)

Comment 26

16 years ago
Comment on attachment 88403 [details]
New publish images integrated into themes toolbar graphic

r=cmanske
Attachment #88403 - Flags: review+
Comment on attachment 88403 [details]
New publish images integrated into themes toolbar graphic

sr=jst
Attachment #88403 - Flags: superreview+
(Assignee)

Comment 28

16 years ago
File "mozilla/themes/modern/editor/icons/btn1.gif" checked into trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Keywords: adt1.0.1, mozilla1.0.1
Resolution: --- → FIXED
Whiteboard: publish, icon [adt2 RTM] [ETA 6/20/02] → publish, icon [adt2 RTM] [ETA 6/20/02][fixed in trunk]
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 29

16 years ago
Verified, new icon is there.
Status: RESOLVED → VERIFIED

Updated

16 years ago
Attachment #88403 - Flags: approval+

Comment 30

16 years ago
please checkin to the 1.0.1 branch. once there, remove the "mozilla1.0.1+"
keyword and add the "fixed1.0.1" keyword.
Keywords: mozilla1.0.1 → mozilla1.0.1+

Comment 31

16 years ago
Adding adt1.0.1+ on behalf of the adt for checkin to the 1.0 branch, pending an
ok from Steve Rudman.  Please get drivers approval before checking in. When you
check this into the branch, please change the mozilla1.0.1+ keyword to fixed1.0.1
Keywords: adt1.0.1 → adt1.0.1+
(Assignee)

Comment 32

16 years ago
checked into mozilla 1.0.1 branch
Keywords: mozilla1.0.1+ → fixed1.0.1
Whiteboard: publish, icon [adt2 RTM] [ETA 6/20/02][fixed in trunk] → publish, icon [adt2 RTM] [ETA 6/20/02][fixed in trunk and branch]

Comment 33

16 years ago
pmac - pls verify this fix on the 1.0 branch tomorrow. thanks!
Whiteboard: publish, icon [adt2 RTM] [ETA 6/20/02][fixed in trunk and branch] → publish, icon [adt2 RTM] [ETA 6/21]

Comment 34

16 years ago
Verified on netscape branch build (2002-07-24-08-1.0.0)
Keywords: verified1.0.1

Updated

16 years ago
Keywords: fixed1.0.1
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.