Animated gif in ImageLayer doesn't animate unless something else triggers a composition

RESOLVED DUPLICATE of bug 1220082

Status

()

RESOLVED DUPLICATE of bug 1220082
3 years ago
3 months ago

People

(Reporter: mstange, Unassigned)

Tracking

({regression})

Trunk
All
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox47 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8724029 [details]
testcase

The gif in this testcase doesn't animate unless I trigger a composition for example by moving the mouse over the tabs.

I found this while looking at bug 1251382.

Comment 1

3 years ago
Regression window(not animating unless resize window or switch tabs):
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2a61df4eaa2d&tochange=24ba8274ed60

Triggered by: 	823227372483	Bas Schouten — Bug 1107297: Only recomposite the damaged rect with D3D11. r=jrmuizel

Comment 2

3 years ago
(In reply to Alice0775 White from comment #1)
> Regression window(not animating unless resize window or switch tabs):
> https://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=2a61df4eaa2d&tochange=24ba8274ed60
> 
> Triggered by: 	823227372483	Bas Schouten — Bug 1107297: Only recomposite the
> damaged rect with D3D11. r=jrmuizel

tested on Windows7.
Removing "regressionwindow-wanted" keyword based on comment 1 where the regression window was provided.
Keywords: regressionwindow-wanted
(Reporter)

Comment 4

3 years ago
This is being fixed in bug 1220082.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1220082
status-firefox47: affected → fixed

Updated

4 months ago
Product: Core → Core Graveyard

Updated

3 months ago
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.