Search engine icon in search bar replaced by magnifying glass

RESOLVED DUPLICATE of bug 1102922

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 1102922
2 years ago
2 years ago

People

(Reporter: FCqzsFMrsieN3hpkERKg, Unassigned)

Tracking

44 Branch
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
This is a longstanding issue with Firefox's search bar, but the previous workaround, which was to enter "about:config" into the address bar and set browser.search.showOneOffButtons to false, became ineffectual in late 2015.

Now that the active search engine is hidden, a web search requires the user to make two active queries: first she queries Firefox as to the active search engine; then she queries the desired search engine. Optimally, the active search engine is evident without query; the user need query only the search engine. 

Because searching the web is a core Firefox function, small optimizations and degenerations in search bar design are amplified in user experience.

Comment 1

2 years ago
Unfortunately it was decided not to implement any workarounds for this painful issue.
It can probably solved by extension "Classic Theme Restorer".
If you want to leave a comment - please do it in bug 1102922 (but it doesn't look very effective)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1102922
(Reporter)

Comment 2

2 years ago
Thanks for pointing out the right place, arni2033. I have two or three cents to contribute there, for whatever good it does.
You need to log in before you can comment on or make changes to this bug.