Closed Bug 1102922 Opened 5 years ago Closed 4 years ago

Difficulty in noticing what the default search engine is

Categories

(Firefox :: Search, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox34 - wontfix

People

(Reporter: petruta.rasa, Unassigned)

References

Details

On search toolbar "Search" text is displayed by default instead of the search engine's name (option present on other versions). This makes it difficult for users to know what search engine they are using since no icon or name are shown. 
Opening "Manage search engines" may not come in handy for some users.

The search engine used is shown only if a text is entered in the search field.

Also, bug 1026568 should be uplifted to Firefox 34 so the search field from about:home and about:newtab can show what search engine is being used.
You can see what the default search engine is by hovering your mouse over the search field, a popup will appear stating "Search using <search engine name>". But I agree, there should be an easier way of identifying what search engine is currently being used.
We decided to do this intentionally, but this is a potential issue that we should try to monitor and potentially address in a followup.
Without a visual indication of what engine is to be searched (as was indicated by the favicon of the search engine and the text name of the search engine in the toolbar prior to firefox 34.0 in the en_US build), it is not possible to type a term in the toobar search box, hit enter, and know what engine is going to be searched.  I frequently use the pulldown to pick a current search engine (e.g. search on Wikipedia), run some series of searches using that engine, then switch to another search engine (e.g. sourceforge) for some other series of searches.  I can't effectively do this with Firefox 34 en_US, and have had to switch to en_GB to get a usable toolbar search box back.  The two features that are missing from the new search box are (1) a visual indication of which engine is the current default, and (2) an easy ability to switch the current default on the fly.
Duplicate of this bug: 1107580
Duplicate of this bug: 1118386
Duplicate of this bug: 1109808
(In reply to mole from comment #3)
> [...] The two features that are missing from the new
> search box are (1) a visual indication of which engine is the current
> default, and (2) an easy ability to switch the current default on the fly.

I completely agree with that.

The magnifying glass is not as informative as the former use of the favicon and text name of the current search engine. And it takes too long to change the default search engine: 5 clicks instead of 2 prior to Firefox 34.
Duplicate of this bug: 1197480
As said in comment 2, this change was intentional. The rational behind that change was that now that we support one-off engines, typing in the search field is no longer associated only with search with the default engine.

(In reply to Blutin from comment #7)
> And it takes too long to change
> the default search engine: 5 clicks instead of 2 prior to Firefox 34.

Once bug 1110771 lands, this should be down to 3 clicks.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
I am surprised that you wontfix this issue that affects a lot of users.
This issue shows an hard accessibility of this bar. A right click is not possible or not easy on all systems. Numerous users do not use it. I noted that hovering mouse is not possible on touch screen or with great difficulties. Some laptops that are not tablets have mouse or pad "and" touch screen.

When the address bar is used to search, how can we know what is the engine that will be used ?

I am sorry to tell you that this present action is a little cavalier.

Please, reopen this issue.

Regards.
(In reply to rpnpif from comment #10)
> I am surprised that you wontfix this issue that affects a lot of users.
> This issue shows an hard accessibility of this bar. A right click is not
> possible or not easy on all systems. Numerous users do not use it. I noted
> that hovering mouse is not possible on touch screen or with great
> difficulties. Some laptops that are not tablets have mouse or pad "and"
> touch screen.

I don't understand your point. As soon as you start typing in the searchbar, you'll see a panel that shows at the top of it what the default engine is. I don't see how touch screens or accessibility relate to this.

The only mention of a right click in this bug is about *changing* the default engine, not noticing what it is.

> When the address bar is used to search, how can we know what is the engine
> that will be used ?

The address bar is off topic for this bug, that is about a change of the searchbar UI we made in Firefox 34.
(In reply to Sam Hall from comment #11)
> For now you can still switch off most of the newfangled behaviour with
> about:config browser.search.showOneOffButtons option. Then you get your
> search engine icons back and most of the old behaviour.

Thank you very much, Sam ! It is what I want !

(In reply to Florian Quèze [:florian] [:flo] from comment #13)

I am using LTS version (now 38) so as all users that used LTS, we discovered this new search bar and we are disappointed.
I am keen to keep the old behaviour. In one click we can change the default search engine with permanent visibility.
Please let us the choice.
(In reply to rpnpif from comment #14)
> I am using LTS version (now 38) so as all users that used LTS, we discovered
> this new search bar and we are disappointed.
> I am keen to keep the old behaviour. In one click we can change the default
> search engine with permanent visibility.
> Please let us the choice.

I don't have a problem with the one off search feature, I just don't like the way it was delivered to me initially in a clearly very broken state. I also don't know how appropriate it was to introduce something that is clearly a new feature posted in a bug tracker as some kind of a bug fix and then rapidly pushed out as one of the buggiest features I've yet to encounter in a stable release of any web browser since IE6. I'd hope that Mozilla take something away from this experience to reduce the chance of it happening yet again.

Firefox was never really intended for corporate use, it just happened to be the best tool in this space for quite a while. When the time comes and the option to avoid the new quick search is removed, your only choice is to build a plugin that behaves exactly how you want. I've managed to maintain the Firefox I know and love only thanks to other peoples effort on this front (menu, tabs and bookmarks toolbar where they belong, status bar down the bottom. Personally, I find the original layout was simply more productive. If there are enough of the right sort of people that dislike this new search bar then we might get lucky and someone will do the (not insignificant) work to build and maintain it.

For Firefox it seems the target audience usually just want to find and watch 30 second youtube videos some something similarly brain dead. Browser's should foster that behaviour in this day and age. People don't have time or the attention span to tame their computers and apparently expect computers to tell them what to do now. I just have to assume that's the case because that's what the current UI trends for electronic devices seem to suggest.

Actually, I suspect if there are global scale UI mistakes being made, you can probably blame patent law for some of the more misguided trends out there. I can only imagine the poor UI designer at some big corporation taking the 50th iteration of his user interface to the legal team for their input after considering possible patent potential or infringement concerns. With such influences, how could you not end up with an unintuitive, barely unusable but pretty and highly patentable UI. That was the only explanation I could come up with for that weird "shake the window to minimise everything except this window" feature in Win7. I'm still convinced that one day someone will rediscover the Windows XP style desktop experience and make millions. That is unless we get brain jack implants in the mean time. Anyway, my goal here was not to go completely off topic but just suggest that perhaps because the majority of the population are eating this dogfood, people are getting used to it. Good design choices for all users or not, Firefox really has no choice but to follow suit if it wants to stay in the game.

Oops, that rant went on a little longer than expected. Speaking of inappropriate posts to a bug tracker... oh well, when in Rome :)
Duplicate of this bug: 1208774
I will point out that if you have an addon that lets you alter the browser's style sheets (such as Stylish), you can restore the search engine icon with a pair of rules like this:

.searchbar-search-button-container { display: none !important; }
.searchbar-engine-button { display: block; padding-left: 3px !important; }

The search engine icon element still exists in browser.xul, it's just hidden by default.

At the very least, there should be an about:config option that toggles whether the icon is shown, or the magnifying glass is shown.  I'd prefer that the engine icon be shown by default, since I'm not sure what advantage there could possibly be to showing the magnifying glass instead.
(In reply to bugzilla from comment #17)
Your proposals are not usable by beginners.
But the beginners should be more protected against leakage of private data as the transmission of all their searched words to the default engine.
(In reply to bugzilla from comment #17)
> you can restore the search engine icon with
> a pair of rules like this:
> 
> .searchbar-search-button-container { display: none !important; }
> .searchbar-engine-button { display: block; padding-left: 3px !important; }
> 
> The search engine icon element still exists in browser.xul, it's just hidden
> by default.

This suggestion won't work in Firefox 43 and later, as the xul element with the searchbar-engine-button class has been removed in bug 1119250.

For people who really want to see the current search provider's icon instead of the glass icon, the best solution would be to make an add-on doing just that.
(In reply to Florian Quèze [:florian] [:flo] from comment #19)
> This suggestion won't work in Firefox 43 and later, as the xul element with
> the searchbar-engine-button class has been removed in bug 1119250.
> 
> For people who really want to see the current search provider's icon instead
> of the glass icon, the best solution would be to make an add-on doing just
> that.

The *best* solution would be to put it back the way it was, where it showed the icon by default instead of a useless magnifying glass.  Why was this changed in the first place?
(In reply to bugzilla from comment #20)

> Why was this changed in the first place?

This is explained in comment 9.
(In reply to Florian Quèze [:florian] [:flo] from comment #21)
> (In reply to bugzilla from comment #20)
> 
> > Why was this changed in the first place?
> 
> This is explained in comment 9.

Fair enough, but hardly an improvement.  There should be an option added to show this element by default, rather than removing functionality that already existed and worked fine and saying "put it in an addon."
Duplicate of this bug: 1234134
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: WONTFIX → ---
(In reply to Florian Quèze [:florian] [:flo] from comment #21)
> (In reply to bugzilla from comment #20)
> 
> > Why was this changed in the first place?
> 
> This is explained in comment 9.

This didn't actually answer anything. Why we need to have "on-off" feature in the first place? Is this a majority users' demand? Is this a new trend that is popular among other browsers? 

From bug 1088660 it LOOKS like just your *personal* idea, and it instantly got lots support from several mozilla employees came from nowhere with no actual survey to users. And no offence here, you're not even Mozilla's employee (or you ARE, but don't like to use @mozilla.com idnetity because it would be inconvenient?) which is also a little bit weird since this is a big UX change to direct.

I don't want to build conspiracy so let us all be honest here, is the whole thing related to default search engine deal with Yahoo? Or put it more straightforwardly, the UI change is so that user cannot easily change the default search engine (because on the "old" design every time users search with other engines, it replaces the default engine)? I think so because:

1 the time window matched.

2 It happened so fast, unlike other function improvement. It didn't even go through the nightly->dev->beta cycle.
Check: 
-https://bugzilla.mozilla.org/show_bug.cgi?id=1088660#c56
-https://bugzilla.mozilla.org/show_bug.cgi?id=1088660#c63
-https://bugzilla.mozilla.org/show_bug.cgi?id=1088660#c72
I saw 3 queries in that one single bug ticket and saw zero response about this abnormality.

And the direct consequence (of skipping thorough testing) is this notorious "bug": https://support.mozilla.org/en-US/questions/1041571#answer-677594

3 Yahoo got mentioned by another Mozilla's employee directly: https://bugzilla.mozilla.org/show_bug.cgi?id=1088660#c57
Well, this one is basically gave it away.

I mean *if* this is true, it's pretty understandable. The development of Firefox (and Mozilla) needs money. And we're talking about a big money. But I really get tired about the pretending game. I tried different ways to convince other users (and devs, hopefully) on different places, forums, reddit, here why the old one is technically better, or least equal to the new one. Then I realize all the effort is irrelevant. I feel like an idiot. To be 100% honest, the UI itself doesn't matter at the end. I changed it back with CTR in 5 seconds with zero effort. But my sanity just can't accept this.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → WORKSFORME
Sorry for change the status of the bug ticket. it doesn't let me post comment for some reason unless I do some change. Please change the status of this bug to WONTFIX (I don't have the privilege to do so).
Resolution: WORKSFORME → WONTFIX
(In reply to Benjamin Peng from comment #24)
> Why we need to have "on-off" feature in the first place?

We (Mozilla) want to encourage users to use more than one search engine (to encourage diversity on the web, and avoid reinforcing the dominance of the already dominant player). The old searchbar UI encouraged using only the default engine, which didn't align well with our values.

> From bug 1088660 it LOOKS like just your *personal* idea, and it instantly
> got lots support from several mozilla employees came from nowhere with no
> actual survey to users.

It wasn't "my" idea, I just spent a couple minutes to write a description for the bug.

> you're not even Mozilla's
> employee (or you ARE, but don't like to use @mozilla.com idnetity because it
> would be inconvenient?)

I am. I don't use an @mozilla.com address for bugzilla because I use this bugzilla account both for my Firefox work and for work I do on my spare time on a project that isn't officially supported by Mozilla (see http://www.instantbird.com).

> I don't want to build conspiracy so let us all be honest here, is the whole
> thing related to default search engine deal with Yahoo?

The "whole thing" wasn't directly related to the search deal change, as it was a project that had been considered for a while. The rushed timing (as you observed from looking at bug 1088660) was related to the announcement of the Yahoo deal.

> Or put it more
> straightforwardly, the UI change is so that user cannot easily change the
> default search engine (because on the "old" design every time users search
> with other engines, it replaces the default engine)?

"cannot easily change the default search engine" isn't accurate, given how big and visible the "Change Search Settings" button is. But some details of the new UI were designed so that users would give a fair chance to a new default (so not change back just at the first sight of an unfamiliar icon, or change default unintentionally as a side effect of doing one search with a different engine).

> I mean *if* this is true, it's pretty understandable.

Thanks for your understanding! :-)
(In reply to Florian Quèze [:florian] [:flo] from comment #19)
> This suggestion won't work in Firefox 43 and later, as the xul element with
> the searchbar-engine-button class has been removed in bug 1119250.
> 
> For people who really want to see the current search provider's icon instead
> of the glass icon, the best solution would be to make an add-on doing just
> that.
In fresh version 44 there is still no effect of  browser.search.showOneOffButtons  
And no other means to show icon instead of the looking glass.

My urged need is for the Scroll Search Engines addon.
I'd prefer to have this feature in basic distribution.
Now Mouse scroll has no functionality for the Search Widget - to scroll them is a worthwhile one.

Also see recent comments at the addon page https://addons.mozilla.org/ru/firefox/addon/scroll-search-engines/
Personally from me: it is very ergonomic feature (see accelerators in IE)
For me, this bug is about Location bar:
I often change search engines, and most of the time I used to just copy-paste text in location bar and quickly press Enter. Now I have to open searchbar menu to make sure I'm using the right engine.
So now I have to use_mouse before that keyboard action. It was way easier with the good old UI.
This fix should be live now in production.
Duplicate of this bug: 1251876
Resolve it, please!

In FF 45.0  Scroll Search Engines https://addons.mozilla.org/ru/firefox/addon/scroll-search-engines/
is ultimately broken now.

Florian, destroy all OneOffButtons squalor, get our browser back!

at least, describe config workround  and incorporate scrolling search engines with mouse
Someone fixed this bug! Use the Old search add-on:

https://addons.mozilla.org/en-US/firefox/addon/old-search1/
@SherDim A user review says that the scroll search engines functionality isn't restored with the Old search add-on, unfortunately.
Firefox's update to 46.0 not only does nothing to fix the broken search bar, but it breaks the add-on that fixed it (Old search).
Updated  Scroll Search Engines 1.1.1 by by Einar Egilsson
works in FF 45+ and also ADDS SEARCH ENGINE ICON to the widget
So it is a real workaround for the topic problem.
Thanks to Einar!!

https://addons.mozilla.org/en-US/firefox/addon/scroll-search-engines/
See Also: → 1119987, 1204252
You need to log in before you can comment on or make changes to this bug.