The list of tabs is scrolled by very small number of tabs when I rotate mouse wheel (with setting "scroll by 1 page")

VERIFIED FIXED in Firefox 48

Status

()

Firefox
Tabbed Browser
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: arni2033, Assigned: mstange)

Tracking

({regression})

Trunk
Firefox 49
regression
Points:
---

Firefox Tracking Flags

(firefox47- wontfix, firefox48+ fixed, firefox49 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
>>>   My Info:   Win7_64, Nightly 47, 32bit, ID 20160225030209
STR:
0. Set mouse option "when I rotate mouse wheel" in your OS to "scroll by 1 page"
1. Open many tabs to cause overflow in Tabs Toolbar
2. Let say you got N fully visible tabs in tabs toolbar.
3. Open attached "testcase 1" in a new window, type N in <input> on that page, click the button.
  (If popup windows are prohibited, allow them, then click the button again)
4. Scroll tabs list to the beginning
5. Hover mouse over the 1st tab
6. Rotate mouse wheel down once

AR:  Tabs list is scrolled to the end.
ER:  Tabs list should be scrolled by ~N tabs to the right

Note:
 On the normal pages, rotating mouse wheel down scrolls the page by visible amount of lines.
 So if similar functionality is presented in Tabs Toolbar, I expect it to work the same way.
 Currently if I scrolled tabs list to the beginning and want to select the 2*N th tab,
 I have to hover mouse over the right scrollbutton, hold left mouse button and
 spend much time to scroll tabs list to the 2*N th tab.
Comment hidden (spam)
Comment hidden (obsolete)
(Reporter)

Updated

2 years ago
See Also: → bug 1253484
(Reporter)

Updated

a year ago
Blocks: 1257815
(Reporter)

Comment 3

a year ago
This was regressed even more after bug 1263975. And I won't report a new bug for the same thing.
Blocks: 1263975
No longer blocks: 1257815, 318168
Keywords: regression
Summary: The list of tabs is scrolled to the beginning/end when I rotate mouse wheel (with setting "scroll by 1 page") → The list of tabs is scrolled by very small number of tabs when I rotate mouse wheel (with setting "scroll by 1 page")
Not tracking for 47, since this seems to be an old regression (albeit it one recently made worse?).
tracking-firefox47: --- → -
(Assignee)

Comment 5

a year ago
Created attachment 8749304 [details] [diff] [review]
patch
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Attachment #8749304 - Flags: review?(enndeakin)
(Assignee)

Comment 6

a year ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=2cf930b54c10
Attachment #8749304 - Flags: review?(enndeakin) → review+

Comment 7

a year ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/aec47fd867ba

Comment 8

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/aec47fd867ba
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox49: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 49
Arni, how is this in nightly now? I can try going through the other bugs you mention in "see also". We also could uplift this fix to aurora 48 if it's verified fixed in 49.  Too late for 47 uplift though.
status-firefox47: affected → wontfix
status-firefox48: --- → affected
tracking-firefox48: --- → +
Flags: needinfo?(arni2033)
Markus, want to request uplift to aurora? If you think it's not too risky that is.
Flags: needinfo?(mstange)
(Assignee)

Comment 11

a year ago
Comment on attachment 8749304 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: has always been broken, but bug 1263975 made it even more broken (before bug 1263975, scrolling was way too fast, after bug 1263975 scrolling was way too slow)
[User impact if declined]: Windows users who have the scroll wheel system setting "Scroll by 1 page" will experience very slow scrolling in the tab bar and in scrollable menus, like the tab list dropdown.
[Describe test coverage new/current, TreeHerder]: I did a fair amount of manual testing. automated test coverage is low - there is one existing test that checks that scrolling the affected elements scrolls in the right direction, but no test that makes sure that we scroll by one page.
[Risks and why]: low - There's not much that can go wrong and I tested it locally. If there are bugs in the patch then only users with this (admittedly rather exotic) system setting will be affected, and it can't get much worse than without this patch
[String/UUID change made/needed]: none
Flags: needinfo?(mstange)
Attachment #8749304 - Flags: approval-mozilla-aurora?
Comment on attachment 8749304 [details] [diff] [review]
patch

Tested manually, has been in m-c for a while, let's uplift and verify in aurora.
Attachment #8749304 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

a year ago
Duplicate of this bug: 1251980
(Reporter)

Comment 14

a year ago
>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160522030240
I don't see any problems with scrolling tabs with mouse option set to "scroll by 1 page", for the first time in 5 years I'm using the browser (compare comment 0 and comment 3).
Rotating mouse N times results in [scroll by visible amount of tabs] performed N times.
Note that I have NOT tested it with extensions that change tab witdh, e.g. "FaviconizeTab".

(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #9)
> I can try going through the other bugs you mention in "see also".
You're right, I mentioned several bugs in comment 2, but they are unrelated now. To get more info 
about Firefox breakage resulting in many sites being unusable for many years, read (whole) bug 1257815
Status: RESOLVED → VERIFIED
Flags: needinfo?(arni2033)

Comment 15

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/80c89a78cae5
status-firefox48: affected → fixed

Updated

a year ago
Duplicate of this bug: 1275657
You need to log in before you can comment on or make changes to this bug.