Closed Bug 1252048 Opened 4 years ago Closed 4 years ago

crash in <name omitted> | mozilla::dom::Event::InitEvent

Categories

(Core :: Web Speech, defect, critical)

45 Branch
x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox45 --- affected
firefox46 --- unaffected
firefox47 --- unaffected

People

(Reporter: adalucinet, Unassigned)

References

Details

(Keywords: crash, reproducible)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-a267cd63-ace1-4925-a1a4-e10872160229.
=============================================================
Affected versions: 45 beta 10 (Build ID: 20160225145837)
Affected platforms: Mac OS X 10.11.1, Mac OS X 10.9.5

Prerequisites: 'media.webspeech.synth.enabled' pref is set to true via about:config page

Steps to reproduce:
1. Launch Firefox and navigate to http://codepen.io/matt-west/pen/wGzuJ
2. Type some long text and click the "Speak" button.
3. While the sound is on, restart Firefox via Developer Toolbar - open the Developer Toolbar (Shift+F2), type 'restart' and hit Enter.

Additional notes:
1. Not a regression - not reproducible with 43.0b9, with 'media.webspeech.synth.enabled' set to true (NOTE that there is no sound available via the test page), but the crash is reproducible with 44.0b1 (Build ID: 20151216164151) where Text to Speech feature works → bp-32684f8e-9ac5-4921-b7c3-b84f32160229; 
2. Unable to reproduce with latest 46.0a2 nor 47.0a1 (from 2016-02-28), e10s disabled.
See Also: → 1252051
So this is reproducible every time on 45.0b10?
Oh, and with e10s, it's just as reproducible just with the signature in bug 1252051?
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #1)
> So this is reproducible every time on 45.0b10?
Yes, every time when following comment 0's STR.

> Oh, and with e10s, it's just as reproducible just with the signature in bug 1252051?
Yes
If this doesn't occurs on 46, this may be bug 1230533
Keywords: reproducible
I'm going to follow mconley's example from bug 1252051, and close this as worksforme.

If this is not reproducible in 46 or 47 then it has been fixed (probably in bug 1230533). 45 is not really a concern since this feature is not preffed on by default.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.