in outlook.office365.com web app mail editor doesn't always show consecutive spaces, also highlighting and backspace bugs

RESOLVED FIXED
(Needinfo from 2 people)

Status

()

Core
Editor
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: benl, Unassigned, NeedInfo)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(platform-rel +)

Details

(Whiteboard: [platform-rel-Microsoft][platform-rel-Outlook])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0 SeaMonkey/2.44a1
Build ID: 20160205232941

Steps to reproduce:

In outlook.office365.com web email client:

Opened new html email for editing.

Typed in (w/o quotes) "asdf asdf asdf asdf".

Moved cursor to the left of the first space.

Pressed space.


Actual results:

Cursor moved to the right of the space.


Expected results:

Space should have been inserted at the cursor, with cursor now between two spaces.

Comment 1

2 years ago
We need a reduced testcase.
Component: Untriaged → Editor
Product: Firefox → Core
(Reporter)

Comment 2

2 years ago
This but report derives from my comment in https://bugzilla.mozilla.org/show_bug.cgi?id=971916

Another commenter could not reproduce this bug in Firefox 44 or 47.

This bug happens for me in Firefox 44.0.2, and Seamonkey 2.39.  It also happens in Seamonkey 2.44a1 in safe mode in a clean profile.  I can't get it to happen in Google Chrome version 48.0.2564.116 m.

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0 SeaMonkey/2.44a1

This only happens when the outlook mail editor is set to produce html emails.  When set to text emails it works without bugs.

Also, sometimes backspace stops doing anthing in the middle of a line, or highlighting lines may not work when pressing the shift key and the down arrow.

I don't know if it means anything but there are a lot of warnings and errors in the error console.  Perhaps the outlook account I have access to is somehow set up differently and this may not be a Firefox/Seamonkey bug.  However it does work fine in Google Chrome.

Sample error console errors:

Timestamp: 2/29/2016 2:05:06 AM
Warning: Error in parsing value for 'left'.  Declaration dropped.
Source File: https://outlook.office365.com/owa/
Line: 0, Column: 32
Source Code:
height: ; width: ; top: ; left: ; display: inline;

Timestamp: 2/29/2016 2:04:56 AM
Error: The stylesheet https://r1.res.office365.com/owa/prem/16.1106.13.1916194/scripts/microsoft.owa.core.controls.editorbase.js was not loaded because its MIME type, "application/x-javascript", is not "text/css".
Source File: https://outlook.office365.com/owa/
Line: 0

Timestamp: 2/29/2016 2:28:41 AM
Error: AbortError
Source File: https://r1.res.office365.com/owa/prem/16.1097.12.1916194/scripts/microsoft.owa.core.storage.js
Line: 2
(Reporter)

Comment 3

2 years ago
"reduced test case"

I don't know what that is but if I can help....
Whiteboard: btpp-followup-2016-03-03
Whiteboard: btpp-followup-2016-03-03 → btpp-followup-2016-03-03 [platform-rel-Microsoft][platform-rel-Outlook]

Updated

2 years ago
platform-rel: --- → ?
Masayuki, can you reproduce these issues?
platform-rel: ? → +
Flags: needinfo?(masayuki)
Whiteboard: btpp-followup-2016-03-03 [platform-rel-Microsoft][platform-rel-Outlook] → [platform-rel-Microsoft][platform-rel-Outlook]
Sorry, I couldn't try to test today. I'll try to do it next week.
Oops, sorry for the delay. I completely forgot this bug.

I tried to test this today, but I realized that the URL is for Office365. Unfortunately, I don't have a license of it.  But fortunately, I succeeded to reproduce this bug in Outlook.com. I hope they share same library...

When I type space before a whitespace, then, the text node is separated to 2 nodes at the insertion point. According to the devtools, these text nodes are "asdf " and " asdf". So, the tail of the first text node and the head of the last text node are collapsed for conforming to HTML's rules.

On the other hand, Chromium separates the text nodes as: "asdf " and " asdf".  Therefore, the spaces are not collapsed.

According to this testcase: https://jsfiddle.net/d_toybox/gxhp2po0/ Google Chrome also collapse white spaces if the first text node ends with ASCII whitespace.

Therefore, I tried to create a simple testcase from this *behavior*:
https://jsfiddle.net/d_toybox/gxhp2po0/1/

Then, Chromium also works as Firefox. So, I guess that Microsoft does not support Firefox this case.

overholt, do you know somebody who can confirm MS what does actually?
Flags: needinfo?(masayuki) → needinfo?(overholt)

Comment 7

2 years ago
Ted works on O365 for Microsoft and replied about a recent bug in O365 (https://bugzilla.mozilla.org/show_bug.cgi?id=1306001#c25). CC'ing him to know if he could help us.
Flags: needinfo?(teddin)
Flags: needinfo?(overholt)
:masayuki -san, let's ping our MSFT DL about this. It contains a number of Outlook engineers
Flags: needinfo?(masayuki)

Comment 9

2 years ago
Please let me know if you do not get any answers from the DL. I actually work on the Web Platform at Microsoft, NOT on O365.
Posted to the ML, sorry for the delay due to not good health condition.
Flags: needinfo?(masayuki)
Flags: needinfo?(davem)

Updated

2 years ago
Rank: 10
Update from the ML:

> This issue is relate the undo logic in editor. Open bug OM 3265235 to track.
Update via ML from OWA engineer says: "This issue (OM 3265235) has been fixed in 12/5/2016."

Can we confirm?
Flags: needinfo?(masayuki)
As I said, I cannot test this with Office 365, I confirmed that this was fixed in at least Outlook.live.com.
Flags: needinfo?(masayuki)
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.