[e10s] Images glitch worsens in sites that use a popular KenBurns slider with Disabled HWA on Windows7

RESOLVED DUPLICATE of bug 1253386

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1253386
2 years ago
2 years ago

People

(Reporter: Alice0775 White, Assigned: lsalzman)

Tracking

({regression})

46 Branch
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 unaffected, firefox46 unaffected, firefox47 fixed)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

2 years ago
[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

+++ This bug was initially created as a clone of Bug #1252046 +++

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0 ID:20160229030448

Reproducible : always

Steps To Reproduce:
1. Disabled HWA
2. Open http://wowslider.com/it/banner-maker-geometric-kenburns-demo.html


Actual Results:
 Images glitch, tremendous badly
 See capture: https://www.youtube.com/watch?v=2BXhfR99e0c

Expected results:
 No glitch

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d8e260e1535f0ff3877b21d6846380dedf449453&tochange=6630a176477ef903dcf3057db755abc43ba5018d

Regressed by: Bug 1082598


Graphics
--------

Adapter Description: AMD Radeon HD 6450
Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 1024
Asynchronous Pan/Zoom: wheel input enabled; touch input enabled
ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300
Device ID: 0x6779
DirectWrite Enabled: false (6.2.9200.17568)
Driver Date: 7-28-2015
Driver Version: 15.200.1062.1003
GPU #2 Active: false
GPU Accelerated Windows: 0/1 Basic (OMTC)
Subsys ID: 23111787
Supports Hardware H264 Decoding: No; Hardware video decoding disabled or blacklisted
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon HD 6450 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasAccelerated: 0
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
Flags: needinfo?(lsalzman)
Flags: needinfo?(jmuizelaar)
(Reporter)

Updated

2 years ago
OS: Windows 10 → Windows 7
See Also: → bug 1252046
Alice, do we see this on other platforms when canvas is Skia?
Flags: needinfo?(alice0775)
Whiteboard: [gfx-noted]
Comment hidden (offtopic)
(Reporter)

Comment 3

2 years ago
Umm, worsens when e10s on + HWA off.
tracking-firefox46: ? → ---
tracking-firefox47: ? → ---
Summary: Images glitch worsens in sites that use a popular KenBurns slider with Disabled HWA → [e10s] Images glitch worsens in sites that use a popular KenBurns slider with Disabled HWA
Hmm, if this is bad with cairo canvas (comment 2), it shouldn't be a regression from updating skia (comment 0.)  At a first glance, I couldn't find non-Skia related stuff in that bug.
(Reporter)

Comment 5

2 years ago
(In reply to Milan Sreckovic [:milan] from comment #4)
> Hmm, if this is bad with cairo canvas (comment 2), it shouldn't be a
> regression from updating skia (comment 0.)  At a first glance, I couldn't
> find non-Skia related stuff in that bug.

On ubuntu, The glitch is less than on Window.
And also, the regression range is different from comment#0.

Regression window on ubuntu14.04 (e10s on + HWA off):
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=600942ae9823ae85186cd613b65582078489daa4&tochange=432ef38dab958e325c2e56dd4093be023c221043
(Reporter)

Comment 6

2 years ago
Filed Bug 1253386 for Ubuntu.
(Reporter)

Updated

2 years ago
Summary: [e10s] Images glitch worsens in sites that use a popular KenBurns slider with Disabled HWA → [e10s] Images glitch worsens in sites that use a popular KenBurns slider with Disabled HWA on Windows7
(Assignee)

Comment 7

2 years ago
This seems possibly a manifestation of what is already being investigated by Edwin in bug 1253386.

I do not believe updating would have caused this, but rather could have conceivably made the underlying issue more apparent for reasons not yet known. Let's wait and see what Edwin turns up, and hopefully we can just resolve this as a duplicate if he can track down a cause.

The unifying theme here is that Windows 7 and Ubuntu are probably both using image backends (in one case Skia, the other Cairo), so the different regression ranges may just be a red herring.
Flags: needinfo?(lsalzman)
Flags: needinfo?(jmuizelaar)

Updated

2 years ago
Depends on: 1253386
Flags: needinfo?(gwright)
Parking this with Lee to dupe or do follow-up investigation as needed. Note that this is a regression in 46, so it's showing up on the "Firefox Release Health" dashboard [1] as a new regression and potential release blocker.

[1] http://mozilla.github.io/releasehealth/
Assignee: nobody → lsalzman
(Assignee)

Comment 9

2 years ago
I discussed with Edwin, Nical, and Matt regarding what we thought the underlying issue was and the best way to progress with a workaround in the short-term.

The issue seems to be a manifestation of bug 1251257, that we are overwriting the canvas client's buffer while the compositor is using it. This ends up causing tearing.

Matt suspects that we should be fine just to double buffer the canvas client based on the refresh driver synchronization he had implemented here: http://mxr.mozilla.org/mozilla-central/source/layout/base/nsRefreshDriver.cpp#1647

I tested a double-buffering prototype Edwin was working on both under Linux and Windows. I was able to reproduce the issue on both platforms without the patch, and with the patch, the problem was fixed on both platforms.

Since Edwin is already working on this in 1253386, I am going to mark this as a dup.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Depends on: 1251257
Resolution: --- → DUPLICATE
Duplicate of bug: 1253386
Thanks for the quick resolution!

Updated

2 years ago
No longer depends on: 1253386
Flags: needinfo?(gwright)
status-firefox46: affected → unaffected
status-firefox47: affected → fixed
You need to log in before you can comment on or make changes to this bug.