Closed Bug 1252317 Opened 5 years ago Closed 5 years ago

Text smearing with mousewheel scrolling

Categories

(Core :: Graphics: Layers, defect)

47 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1251894

People

(Reporter: jgilbert, Unassigned)

References

()

Details

(Keywords: correctness, Whiteboard: gfx-noted)

Attachments

(2 files)

No description provided.
Keywords: correctness
Whiteboard: gfx-noted
Not much detail to go on but it's likely a dupe of bug 1236593
On that note, if anybody outside gfx had filed this bug we would have required a bunch more info before letting it be "gfx-noted" - I think we should hold ourselves to the same standard. WDYT?
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #2)
> On that note, if anybody outside gfx had filed this bug we would have
> required a bunch more info before letting it be "gfx-noted" - I think we
> should hold ourselves to the same standard. WDYT?

I've given more or less what I expect for an initial volley, though I was terse about the repro. (because the repro is, for me, immediate and obvious)

If it doesn't repro for you, I'm happy to provide more information.

(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #1)
> Not much detail to go on but it's likely a dupe of bug 1236593

The only difference I see is that for me it holds steady with this bad drawing. I don't need to pull it out of a video.

This does sound like a dupe though.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1236593
I'm not able to repro this. Although if it's holding steady with the bad state it sounds much more severe than bug 1236593, which was very transient (per comment 8 on that bug).
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
How do the prefs layers.componentalpha.enabled and gfx.direct2d.enabled affect the reproducibility of this?
Flags: needinfo?(jgilbert)
not sure if its related, but i do see a ghosting effect during scrolling. 
Text elements have his ghost trail during scroll with the mouse wheel 

The saw-tooth pattern on this site shows the effect. 
Im unable to record it properly though   
http://www.awwwards.com/20-best-websites-with-parallax-scrolling-of-2013.html  


Fedora 22 & Nightly 47.0a1 (2016-03-02)
(In reply to Markus Stange [:mstange] from comment #6)
> How do the prefs layers.componentalpha.enabled and gfx.direct2d.enabled
> affect the reproducibility of this?

This reproduces for me with layers.componentalpha.enabled:true (the default), but with layers.componentalpha.enabled:false, it does not.
gfx.direct2d.disabled doesn't change the result.

These are both after restarting the browser after pref change, before testing.
Flags: needinfo?(jgilbert)
Thanks.

Can you turn on paint flashing and see whether we do any main thread painting while the issue is showing itself? I expect that this will show that every main thread repaint resolves the issue briefly, and that the smeared composites are those where there was no main thread paint in between. If this is not the case it would be interesting to know about it.
Flags: needinfo?(jgilbert)
Actually, never mind that. Can you reproduce this in a debug build? Do you see this message being printed?
"Could not copy render target - source rect out of bounds"

If so, I think I know what's going on and will describe the problem in bug 1251894.
I will give this a try.
The patch is now on Nightly.
(In reply to Markus Stange [:mstange] from comment #14)
> The patch is now on Nightly.

Looks better initially on my Mar14 nightly build.
Flags: needinfo?(jgilbert)
Closing as dupe, please reopen if it comes back.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 47 Branch
Duplicate of bug: 1251894
You need to log in before you can comment on or make changes to this bug.