Closed Bug 1252465 Opened 4 years ago Closed 4 years ago

Link taps don't work at the bottom of reader view page

Categories

(Firefox for Android :: Reader View, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 48
Tracking Status
firefox47 --- verified
firefox48 --- verified
fennec 47+ ---

People

(Reporter: Margaret, Assigned: capella)

References

Details

Attachments

(1 file)

This is likely a regression from bug 1226238. I suspect that there's still a transparent toolbar element taking up the full width of the screen, so it's intercepting taps intended for links below.
See Also: → 1258455
Duplicate of this bug: 1258455
Attached patch bug1252465.diffSplinter Review
Good tip-off, confirmed w/WebIDE ... fix seems simple.
Assignee: margaret.leibovic → markcapella
Status: NEW → ASSIGNED
Attachment #8733210 - Flags: review?(margaret.leibovic)
Comment on attachment 8733210 [details] [diff] [review]
bug1252465.diff

Review of attachment 8733210 [details] [diff] [review]:
-----------------------------------------------------------------

Works for me!
Attachment #8733210 - Flags: review?(margaret.leibovic) → review+
https://hg.mozilla.org/mozilla-central/rev/69b843ebaa27
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
Can you request uplift to 47?
Flags: needinfo?(markcapella)
Comment on attachment 8733210 [details] [diff] [review]
bug1252465.diff

Approval Request Comment:  As suggested in comment # 6, please upload to v47 / currently Beta.

[Feature/regressing bug #]: This is likely a regression from bug 1226238.
[User impact if declined]: Sub-optimal UI interaction in an otherwise most-excellent new implementation.

[Describe test coverage new/current, TreeHerder]: All testing done via UI, baked in Aurora, Central, and local queues prior to that.

[Risks and why]: Seems to be none, small change, easily backed out.
[String/UUID change made/needed]: None
Flags: needinfo?(markcapella)
Attachment #8733210 - Flags: approval-mozilla-beta?
Comment on attachment 8733210 [details] [diff] [review]
bug1252465.diff

Regression in reader view, baked in Nightly for a while, Beta47+
Attachment #8733210 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified as fixed on Firefox 47 Beta 4 and latest Aurora on Samsung Galaxy S6 Edge (Android 5.1.1)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.