Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: ferjm, Assigned: ferjm)

Tracking

({dev-doc-needed, site-compat})

unspecified
ARM
Gonk (Firefox OS)
dev-doc-needed, site-compat

Firefox Tracking Flags

(firefox51 fixed)

Details

Attachments

(1 attachment, 3 obsolete attachments)

The Marketplace is removing payments support [1], so we can get rid of all mozPay related code.

[1] https://wiki.mozilla.org/Marketplace#Upcoming_Changes_to_Marketplace
(Assignee)

Updated

3 years ago
Assignee: nobody → ferjmoreno
(Assignee)

Updated

3 years ago
Blocks: 1252143
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 945675
(Assignee)

Comment 3

3 years ago
Posted patch v1 (obsolete) — Splinter Review
(Assignee)

Comment 5

3 years ago
Comment on attachment 8735107 [details] [diff] [review]
v1

Could you take a look at this patch, please?

Fabrice, for the B2G part.

Ehsan, DOM and desktop parts.

Mark, Android parts.

Thanks!
Attachment #8735107 - Flags: review?(mark.finkle)
Attachment #8735107 - Flags: review?(fabrice)
Attachment #8735107 - Flags: review?(ehsan)
Keywords: dev-doc-needed, site-compat
Comment on attachment 8735107 [details] [diff] [review]
v1

Review of attachment 8735107 [details] [diff] [review]:
-----------------------------------------------------------------

Just wait for TV 2.6 to branch before landing.
Attachment #8735107 - Flags: review?(fabrice) → review+

Updated

3 years ago
Attachment #8735107 - Flags: review?(ehsan) → review+
(In reply to Kohei Yoshino [:kohei] from comment #7)
> Posted the site compatibility doc:
> https://www.fxsitecompat.com/en-CA/docs/2016/non-standard-web-payments-api-
> has-been-removed/

This is not yet the case, since this patch has not landed.
/me clicked the button too quickly ;)
Comment on attachment 8735107 [details] [diff] [review]
v1

Review of attachment 8735107 [details] [diff] [review]:
-----------------------------------------------------------------

Stealing this review from mfinkle. I was about to file a bug about removing these mobile tests, since it looks like we missed them as part of bug 1251373.

::: mobile/android/tests/browser/chrome/test_jni.html
@@ -41,5 @@
> -          { name: "getMCC", sig: "()I" },
> -        ],
> -      });
> -      is(typeof jGeckoNetworkManager.getMNC(), "number", "typeof getMNC is number");
> -      is(typeof jGeckoNetworkManager.getMCC(), "number", "typeof getMCC is number");

GeckoNetworkManager still exists. If it's unused, we should have another bug/patch to remove it. I don't think removing this test logic is in the scope of this bug if we still support these methods.
Attachment #8735107 - Flags: review?(mark.finkle) → review+
(In reply to :Margaret Leibovic from comment #10)

> GeckoNetworkManager still exists. If it's unused, we should have another
> bug/patch to remove it. I don't think removing this test logic is in the
> scope of this bug if we still support these methods.

GeckoNetworkManager is still used
(In reply to Mark Finkle (:mfinkle) from comment #11)
> (In reply to :Margaret Leibovic from comment #10)
> 
> > GeckoNetworkManager still exists. If it's unused, we should have another
> > bug/patch to remove it. I don't think removing this test logic is in the
> > scope of this bug if we still support these methods.
> 
> GeckoNetworkManager is still used

In that case, let's not remove this test coverage :)
Sure. Thanks for the review!
Posted patch Remove mozPay. (obsolete) — Splinter Review
Updated patch on top of current central.
Attachment #8735107 - Attachment is obsolete: true
Attachment #8782888 - Flags: review?(fabrice)
(In reply to Alexandre LISSY :gerard-majax from comment #14)
> Created attachment 8782888 [details] [diff] [review]
> Remove mozPay.
> 
> Updated patch on top of current central.

Conflicted:
	b2g/chrome/content/shell.js.rej
	b2g/components/moz.build.rej
	b2g/confvars.sh.rej
	b2g/graphene/confvars.sh.rej
	b2g/installer/package-manifest.in.rej
	browser/confvars.sh.rej
	browser/installer/package-manifest.in.rej
	docshell/base/nsDocShell.h.rej
	dom/base/Navigator.cpp.rej
	dom/base/Navigator.h.rej
	dom/moz.build.rej
	dom/webidl/moz.build.rej
	mobile/android/tests/browser/robocop/robocop.ini.rej
	old-configure.in.rej
Posted patch Remove mozPay. (obsolete) — Splinter Review
Eradicate dom/payment/
Attachment #8782888 - Attachment is obsolete: true
Attachment #8782888 - Flags: review?(fabrice)
Attachment #8782900 - Flags: review?(fabrice)
Attachment #8782900 - Flags: review?(fabrice) → review+
Keeping GeckoNetworkManager assertions as requested in comment 10.
Attachment #8782900 - Attachment is obsolete: true
Attachment #8783438 - Flags: review+

Comment 24

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4a2454585e72
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox51: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.