Clearing "Offline Web Content and User Data" does not clear Service Workers or their caches.

RESOLVED DUPLICATE of bug 1047098

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1047098
2 years ago
9 months ago

People

(Reporter: callahad, Unassigned)

Tracking

(Blocks: 1 bug, {DevAdvocacy, privacy})

Trunk
DevAdvocacy, privacy
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox47 affected)

Details

(Whiteboard: [DevRel:P2])

(Reporter)

Description

2 years ago
STR:

1. Visit https://www.pokedex.org/
2. Preferences -> Advanced -> Network -> Offline Web Content and User Data -> Clear Now

What should happen:

- The service worker is unregistered
- All cached data is cleared

What actually happens:

- The service worker is still visible in about:serviceworkers
- All data cached by the service worker is still present

To verify that cached data persisted, visit https://www.pokedex.org/manifest.json and run the following in the console:

    caches.match('/img/icon-48.png').then(x => console.log(`Resource ${(x && x.ok) ? "WAS" : "WAS NOT"} found in cache:`, x))
(Reporter)

Updated

2 years ago
Blocks: 1253031

Updated

2 years ago
Component: Untriaged → Bookmarks & History
(Reporter)

Updated

2 years ago
Whiteboard: [DevRel:P2]

Updated

2 years ago
Component: Bookmarks & History → General
Fixed by 1047098
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1047098
You need to log in before you can comment on or make changes to this bug.