[kinto] Put chrome.storage.sync behind a feature flag

RESOLVED DUPLICATE of bug 1253740

Status

defect
P2
normal
RESOLVED DUPLICATE of bug 1253740
4 years ago
Last year

People

(Reporter: andy+bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [storage]triaged)

Given that landing the client API is pointless until a server is stood up, let's put all the Firefox code behind a preference flag. Code can keep landing and when its ready to be turned on we'll just flip the preference. Testing can be done by manually going to about:config and flipping the preference.
Summary: Put chrome.storage.sync behind a feature flag → [kinto] Put chrome.storage.sync behind a feature flag
Priority: -- → P2
Whiteboard: [storage] → [storage]triaged
I think you've got this in another bug already right? Should we just close it?
Flags: needinfo?(eglassercamp)
Yes, this work was already done in all the patches for bug 1253740.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(eglassercamp)
Resolution: --- → DUPLICATE
Duplicate of bug: 1253740
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.