[kinto] Mock out server calls so that tests can run

RESOLVED DUPLICATE of bug 1253740

Status

defect
P3
normal
RESOLVED DUPLICATE of bug 1253740
4 years ago
Last year

People

(Reporter: andy+bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [storage] triaged)

Tests run in the try server should be done to a mocked server, so that we aren't dependent upon another service to make those calls. Should probably ping releng on this to find out how similar tests are done for sync.
Summary: Mock out server calls so that tests can run → [kinto] Mock out server calls so that tests can run
Will reuse the Kinto server mock from OneCRL for this.
bob will be inter-acting with them - this is one of the process bugs
Priority: -- → P3
Whiteboard: [storage] → [storage] triaged
Is this bug still relevant?
Component: WebExtensions: Untriaged → WebExtensions: General
Flags: needinfo?(eglassercamp)
I think this work got pulled into the changes for bug 1253740.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(eglassercamp)
Resolution: --- → DUPLICATE
Duplicate of bug: 1253740
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.