Closed Bug 1253930 Opened 5 years ago Closed 5 years ago

Default favicons of 5 recently bookmarked, while in smart folder favicons are OK

Categories

(Firefox :: Bookmarks & History, defect)

47 Branch
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 48
Tracking Status
firefox47 --- disabled
firefox48 --- verified

People

(Reporter: krzysztof.glebowicz, Assigned: mak)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160305030241

Steps to reproduce:

I've noticed a bug in the bookmarks menu.


Actual results:

As in attached screenshot: Favicons of 5 recently bookmarked pages are default (globes). But in smart folder Recently bookmarked and in real folders the same links have specific favicons.
Blocks: 1219804
[Tracking Requested - why for this release]:

Regression window:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=970aa793c5e2778172cd8e527f9dc04848400d40&tochange=f7149b0bcf7491e23edacbffce6fa418b05e776e

Regressed by: f7149b0bcf74	Dão Gottwald — Bug 1250806 - Add menuitems for recent bookmarks synchronously so that they show up in the native menubar on OS X. r=mak
Blocks: 1250806
No longer blocks: 1219804
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Component: Untriaged → Bookmarks & History
Going to track this regression and see if Dao can take this
Flags: needinfo?(dao)
I can take this, the problem is that nsINavHistoryResult already provides a moz-anno:favicon: url, so we don't need to add the prefix.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Flags: needinfo?(dao)
Attachment #8727349 - Flags: review?(dao) → review+
https://hg.mozilla.org/mozilla-central/rev/4b613cad02de
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
I managed to reproduce this issue on Firefox 47.0a1 (2016-03-05) and on Windows 10 x86.
The issue is no longer reproducible on Firefox 48.0a1 (2016-03-08). The tests were performed on Windows 10 x86, Mac OS X 10.11.1 and on Ubuntu 14.04 x64.
I am marking this issue Verified-Fixed.
Status: RESOLVED → VERIFIED
Recent bookmarks have been disabled in 47, so we don't need this.
You need to log in before you can comment on or make changes to this bug.