crash in msmpeg2vdec.dll@0x25a487 @0x1230b2

RESOLVED WORKSFORME

Status

()

defect
P3
critical
RESOLVED WORKSFORME
3 years ago
2 months ago

People

(Reporter: gerald, Unassigned)

Tracking

({crash, crashreportid})

47 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox47 wontfix, firefox48 wontfix, firefox49 wontfix, firefox50 wontfix, firefox51 wontfix, firefox52 wontfix, firefox53 affected, firefox54 affected, firefox55 affected)

Details

(crash signature)

(Reporter)

Description

3 years ago
Lots of crashes on 64-bit Windows 7 SP1, that all use msmpeg2vdec.dll versions 12.0.9200.16426 or 12.0.9200.17037.
Also, e10s seems to always be enabled.

The initial solution in bug 1242343 was too broad (blacklisting 12.0.9200.17037, which is the latest-available DLL on Win7-64 SP1) and effectively disabled H.264 decoding even for systems that didn't experience crashes (see bug 1253395 for more details and a fix to the regression).

So we are back at square one.
(Reporter)

Updated

3 years ago
No longer depends on: 1253923
Does disabling DXVA help to reduce crash rates for this DLL?
Flags: needinfo?(gsquelart)
Priority: P1 → P3
(Reporter)

Comment 2

3 years ago
@0x17229d only happened twice in February 2016, I think we can just forget about it.
Crash Signature: [@ msmpeg2vdec.dll@0x25a487 ] [@ msmpeg2vdec.dll@0x1230b2 ] [@ msmpeg2vdec.dll@0x17229d ] → [@ msmpeg2vdec.dll@0x25a487 ] [@ msmpeg2vdec.dll@0x1230b2 ]
Summary: crash in msmpeg2vdec.dll@0x25a487 @0x1230b2 @0x17229d → crash in msmpeg2vdec.dll@0x25a487 @0x1230b2
(Reporter)

Comment 3

3 years ago
Some remarks about the reports as of today:
@0x25a487 only happens on Nightly (I think), i.e.: 44.0a1, 45.0a1, 48.0a1, 49.0a1, 50.0a1. Also it is fairly low volume: 24 per month.

@0x1230b2 only happened once on release 47 in the past two months. And a few times on 48b and 50a.
It is much more significant on 44 and older, but there is nothing we can do for these ones.

So based on this, I will leave this bug open at P3, and remove my active involvement.
But I'll keep an eye on it, especially after bug 1284672 lands, in case it has a positive impact on this kind of issues.
Assignee: gsquelart → nobody
Depends on: 1284672
Flags: needinfo?(gsquelart)
I think I finally get reproducible steps to get these crashes

STR:
1. Open this website page (care is kinda 'funny" NSFW) - https://www.facebook.com/ligabedzieciekawsza/videos/vb.381367692053033/512073675649100/?type=2&theater
and in more than 50-75% cases, crash will happen, sometimes oddly it didn't crash


Crashlog reports for [@ nvwgf2umx.dll@0x6be8eb ]
https://crash-stats.mozilla.com/report/index/0f02c2f7-2977-48b8-b4ed-2123f2160812
https://crash-stats.mozilla.com/report/index/f279a73b-47e6-422f-8b8a-a8a2c2160812

Crashlog reports for [@ msmpeg2vdec.dll@0x1230b2 ]
https://crash-stats.mozilla.com/report/index/553fd320-6fd8-4b5a-8e1f-9ce252160818
https://crash-stats.mozilla.com/report/index/a3c99117-b630-4261-ba08-afd222160818
https://crash-stats.mozilla.com/report/index/99098506-eba7-4e52-81d9-f97282160818
https://crash-stats.mozilla.com/report/index/413f7ebf-fd1a-43c6-b934-9cc7a2160818


what I observed is that normally I get in Graphics section in about:config
>Hardware H264 Decoding	Yes; Using D3D9 API
but before the crash happen, it changes to
>Hardware H264 Decoding: No; Too many DXVA videos playing
maybe it will be some clue to fixing this issue
Flags: needinfo?(gsquelart)
(In reply to Virtual_ManPL [:Virtual] - (ni? me) from comment #4)
> what I observed is that normally I get in Graphics section in about:config
> >Hardware H264 Decoding	Yes; Using D3D9 API
> but before the crash happen, it changes to
> >Hardware H264 Decoding: No; Too many DXVA videos playing
> maybe it will be some clue to fixing this issue
Maybe we have too many active decoders (bug #1287668)
See Also: → 1308863
Gerald, would it be worth adding msmpeg2vdec.dll to the skiplist, as we've done with
gfx driver DLLs in bug 1274345?
(Reporter)

Comment 7

3 years ago
(In reply to Marco Castelluccio [:marco] from comment #6)
> Gerald, would it be worth adding msmpeg2vdec.dll to the skiplist, as we've
> done with gfx driver DLLs in bug 1274345?

Thank you for the offer, Marco.

If I understand correctly, this would collapse all msmpeg2vdec call into one frame, and show the following one, right?
Unfortunately, from what I can see, that remainder of the stack is almost always inside Windows DLLs, which won't help much either, right?

Also, and on the somewhat brighter note, the total number of msmpeg2vdec crashes in recent releases looks fairly low anyway, e.g., ~100 per week on 49.0.1.

In case I'm not seeing the real value, would you be able to give an example of benefits based on the current report crop?
And if it's a simple change with no real downside, we may just want to do it in case something helpful&unexpected comes out of it.
(In reply to Gerald Squelart [:gerald] from comment #7)
> If I understand correctly, this would collapse all msmpeg2vdec call into one
> frame, and show the following one, right?
> Unfortunately, from what I can see, that remainder of the stack is almost
> always inside Windows DLLs, which won't help much either, right?

That is correct.

> Also, and on the somewhat brighter note, the total number of msmpeg2vdec
> crashes in recent releases looks fairly low anyway, e.g., ~100 per week on
> 49.0.1.
> 
> In case I'm not seeing the real value, would you be able to give an example
> of benefits based on the current report crop?
> And if it's a simple change with no real downside, we may just want to do it
> in case something helpful&unexpected comes out of it.

If we have a small number of crashes, then it isn't worth it. We can do it
if/when the number of crashes with msmpeg2vdec.dll becomes concerning.
Mass wontfix for bugs affecting firefox 52.

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.