Reply with selection doesn't work any more

RESOLVED FIXED in Thunderbird 48.0

Status

Thunderbird
Message Compose Window
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: Jorg K (GMT+2), Assigned: Jorg K (GMT+2))

Tracking

({regression})

47 Branch
Thunderbird 48.0
regression
Bug Flags:
in-testsuite ?
in-moztrap ?

Thunderbird Tracking Flags

(thunderbird46 unaffected, thunderbird47 fixed, thunderbird48 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
I've just switched from TB 46 (was Earlybird) to TB 47 (now Earlybird).

When I select a text in an e-mail and press reply, the whole e-mail is quoted in the reply and not just the selected text.

I wonder when/how that broke. Also not working on latest trunk TB 48.
(Assignee)

Updated

2 years ago
Keywords: regression
Flags: in-testsuite?
Flags: in-moztrap?
(Assignee)

Comment 1

2 years ago
This won't be so easy to find. The last good version was Daily of 2016-01-30.

Builds were busted until 2016-02-04 due to the DOM windows stuff (bug 1243760). Immediately when that landed and we could build again, composition was busted due to bug 1245681. Aleth manually cancelled Dailies on the 4th and 5th. One Daily slipped through was built on 6th with busted composition.

The daily that was built on the 2016-02-07 after bug 1245681 landed on M-C already has working composition, but the reply with selection doesn't work.

So the problem occurred anywhere between the 2016-01-30 and the 2016-02-07. Bisecting won't help.
(Assignee)

Comment 2

2 years ago
Created attachment 8728001 [details] [diff] [review]
Revert bad choice made in bug 1243760

Sigh, no one really understood whether it needed to be outer or inner window. Ratty chose to the best of his abilities in bug 1243760 and I checked them all.

Well, we got at least one wrong, this one.
Assignee: nobody → mozilla
Status: NEW → ASSIGNED
Attachment #8728001 - Flags: review?(mkmelin+mozilla)

Comment 3

2 years ago
Comment on attachment 8728001 [details] [diff] [review]
Revert bad choice made in bug 1243760

rs+ = me.
Attachment #8728001 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Comment 4

2 years ago
https://hg.mozilla.org/comm-central/rev/b996b563bc3a
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-thunderbird46: --- → unaffected
status-thunderbird47: --- → affected
status-thunderbird48: --- → fixed
Resolution: --- → FIXED
(Assignee)

Comment 5

2 years ago
Comment on attachment 8728001 [details] [diff] [review]
Revert bad choice made in bug 1243760

[Approval Request Comment]
Regression caused by (bug #): bug 1243760
User impact if declined: Reply doesn't work, not so nice for an e-mail program.
Testing completed (on c-c, etc.): Manual.
Risk to taking this patch (and alternatives if risky):
Not taking it is no option.
Attachment #8728001 - Flags: approval-comm-aurora+
(Assignee)

Comment 6

2 years ago
Landed on Aurora (TB 47):
https://hg.mozilla.org/releases/comm-aurora/rev/bf9217456d7b
status-thunderbird47: affected → fixed
(Assignee)

Updated

2 years ago
Blocks: 1243760
(Assignee)

Updated

a year ago
Target Milestone: --- → Thunderbird 48.0
You need to log in before you can comment on or make changes to this bug.