error: member access into incomplete type 'nsIUUIDGenerator' after bug 1237847

RESOLVED FIXED in mozilla48

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: clokep, Assigned: clokep)

Tracking

({regression})

Trunk
mozilla48
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox48 wontfix)

Details

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
Created attachment 8728165 [details]
Build log

I'm getting build errors in toolkit/xre/nsAppRunner.cpp after bug 1237847 landed. (I verified by backing out 5b20181a5b50 and my build completed).

The error is:

Unified_cpp_toolkit_xre0.o
/Users/pcloke/mozilla/comm-central/mozilla/toolkit/xre/nsAppRunner.cpp:689:17: error: member access into incomplete type 'nsIUUIDGenerator'
    rv = uuidgen->GenerateUUIDInPlace(&uuid);
                ^

I've attached a partial build log.

I suspect this is because I have --disable-accessibility. (https://hg.mozilla.org/mozilla-central/annotate/05c087337043dd8e71cc27bdb5b9d55fd00aaa26/toolkit/xre/nsAppRunner.cpp#l117 maybe similar to bug 990793?)
(Assignee)

Comment 1

3 years ago
Created attachment 8728166 [details] [diff] [review]
Patch v1

I'm not really sure who the right reviewer for this code is, so I chose the same reviewer as bug 1237847, please let me know if this is incorrect.

(I suspect I also filed this bug in the wrong component, but again...I matched the bug that caused the regression.)
Assignee: nobody → clokep
Status: NEW → ASSIGNED
Attachment #8728166 - Flags: review?(bobowen.code)
Component: Plug-ins → Security: Process Sandboxing
Comment on attachment 8728166 [details] [diff] [review]
Patch v1

Review of attachment 8728166 [details] [diff] [review]:
-----------------------------------------------------------------

I can take this. r=me.
Attachment #8728166 - Flags: review?(bobowen.code) → review+
(Assignee)

Comment 3

3 years ago
Thanks!

https://hg.mozilla.org/integration/mozilla-inbound/rev/ba36ba7f03c8
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
status-firefox48: affected → wontfix
You need to log in before you can comment on or make changes to this bug.