Closed Bug 1255461 Opened 4 years ago Closed 4 years ago

Can not set a master password

Categories

(Firefox for Android :: Logins, Passwords and Form Fill, defect, major)

ARM
Android
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 48
Tracking Status
firefox45 --- unaffected
firefox46 --- unaffected
firefox47 + verified
firefox48 --- verified
fennec 47+ ---

People

(Reporter: cos_flaviu, Assigned: jchen)

References

Details

Attachments

(3 files)

Environment: 
Device: Asus ZenPad 8 (Android 5.0.2);
Build: Nightly 48.0a1 (2016-03-10);

Steps to reproduce:
1. Launch Fennec;
2. Go to Settings->Privacy;
3. Set a master password.

Expected result:
The master password is successfully saved.

Actual result:
The master password is not saved.
Severity: normal → major
tracking-fennec: --- → ?
Time to kill master password? Do we know how many people are using it?
Flags: needinfo?(bbermes)
tracking-fennec: ? → 46+
Do you have logs?
Flags: needinfo?(bbermes) → needinfo?(flaviu.cos)
Also it would be helpful to get a regression window.
I'll own figuring out what's going wrong here.
Assignee: nobody → margaret.leibovic
(In reply to :Margaret Leibovic from comment #2)
> Do you have logs?
Attached are the logs form logcat.
Flags: needinfo?(flaviu.cos)
I started using WebIDE to see if I could find a problem on the Gecko side. During the process of setting a Master Password (Settings > Dialog > OK), I never saw a breakpoint get hit in browser.js to handle the preference change.

The Android UI opens the dialog and tries to send the "Preferences:Set" message here:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/java/org/mozilla/gecko/preferences/GeckoPreferences.java#1398
(In reply to Mark Finkle (:mfinkle) from comment #6)
> I started using WebIDE to see if I could find a problem on the Gecko side.
> During the process of setting a Master Password (Settings > Dialog > OK), I
> never saw a breakpoint get hit in browser.js to handle the preference change.
> 
> The Android UI opens the dialog and tries to send the "Preferences:Set"
> message here:
> http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/java/org/
> mozilla/gecko/preferences/GeckoPreferences.java#1398

There is no listener for "Preferences:Set" on the JS side... so that's probably why this isn't working.

This looks like it was caused by bug 1243049.

Not sure why we marked this as tracking 46, this should only affect 46.
Assignee: margaret.leibovic → nchen
tracking-fennec: 46+ → 47+
Blocks: 1243049
This should work.
Attachment #8729645 - Flags: review?(margaret.leibovic)
Comment on attachment 8729645 [details] [diff] [review]
Use PrefsHelper to set master password (v1)

Review of attachment 8729645 [details] [diff] [review]:
-----------------------------------------------------------------

Nice.
Attachment #8729645 - Flags: review?(margaret.leibovic) → review+
(In reply to Barbara Bermes [:barbara] from comment #10)
> http://mzl.la/1TIgNFw??

This bug should only affect 37 and 38
(In reply to Barbara Bermes [:barbara] from comment #10)
> http://mzl.la/1TIgNFw??

We don't set this flag in Fennec, so this data isn't accurate. If we want to measure this, we need to add a histogram probe somewhere, modeled after the desktop version:
http://hg.mozilla.org/mozilla-central/annotate/5e14887312d4/browser/base/content/browser.js#l1360

Want to file a bug for that?
Flags: needinfo?(bbermes)
When "pseudo-prefs" change, the Java side expects the same change
notification as regular prefs.
Attachment #8731275 - Flags: review?(snorp)
Attachment #8731275 - Flags: review?(snorp) → review+
https://hg.mozilla.org/mozilla-central/rev/071a81d2a723
https://hg.mozilla.org/mozilla-central/rev/aa409880028a
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
Comment on attachment 8729645 [details] [diff] [review]
Use PrefsHelper to set master password (v1)

Uplift for *both* patches.

Approval Request Comment
[Feature/regressing bug #]: Bug 1243049
[User impact if declined]: Cannot use the master password feature
[Describe test coverage new/current, TreeHerder]: Locally, m-c
[Risks and why]: Very small; patches only address this bug
[String/UUID change made/needed]: None
Attachment #8729645 - Flags: approval-mozilla-aurora?
Flaviu, could you please verify this issue is fixed as expected on a latest Fennec Nightly build? Thanks!
Flags: needinfo?(flaviu.cos)
Tracked, recent regression in Fx47.
Comment on attachment 8729645 [details] [diff] [review]
Use PrefsHelper to set master password (v1)

Recent regression, was locally verified, Aurora47+
Attachment #8729645 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed in build 48.0a1 2016-03-23;
Device: Asus ZenPad 8 (Android 5.0.2).
Flags: needinfo?(flaviu.cos)
Verified as fixed in build 47.0a2 2016-03-24;
Device: Asus ZenPad 8 (Android 5.0.2).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.