Closed Bug 1255566 Opened 5 years ago Closed 5 years ago

Mozmill update tests failing for Firefox 46 beta

Categories

(Testing Graveyard :: Mozmill, defect)

Version 3
defect
Not set
normal

Tracking

(firefox45 unaffected, firefox46 affected, firefox47- affected, firefox48 affected)

RESOLVED WONTFIX
Tracking Status
firefox45 --- unaffected
firefox46 --- affected
firefox47 - affected
firefox48 --- affected

People

(Reporter: kairo, Unassigned)

References

Details

Running the mozmill-based ondemand update tests, I'm seeing errors, see e.g. http://mm-ci-production.qa.scl3.mozilla.com:8080/job/ondemand_update/22550/ (requires VPN). The error is this:

CRITICAL | Framework Failure | {
  "message": "[JavaScript Error: \"SyntaxError: missing ] after element list\" {file: \"resource://mozmill/stdlib/securable-module.js\" line: 172 column: 21 source: \"                     for each (path in rootPaths)];\n\"}]"
}

The failing code in question is at https://github.com/mozilla/mozmill/blob/hotfix-2.0/mozmill/mozmill/extension/resource/stdlib/securable-module.js#L171

After some conversation with shu on #jsapi, the removal of comprehensions in bug 1220564 is the cause of this issue (though the for-each used there is also deprecated, it's not been removed yet, that's coming in the future in bug 1083470).

If we want to fix this code, we can do |var fses = []; for each (var path in rootPaths) fses.push(new Exports.LocalFileSystem(path));| of is this is just trying to basically do a map operation, something like |Array.from(mapLikeThing, kernelFn)| - but it's unclear if we really want to fix this in the deprecated mozmill.

Alternative solutions are to either switch our ondemand tests to Marionette (probably needs some work and time) or finally move to Marionette-based tests triggered and run by releng infrastructure (probably needs even more work and time but is the long-term solution we need to end up with).

Doing the update testing manually is for sure not the path we can go with, at least not for anything beyond some spot-checks for the current 46.0b1 being released this week. At the latest for b2 early next week we need some sort of solution.
Summary: Mozimill update tests failing for Firefox 46 beta → Mozmill update tests failing for Firefox 46 beta
[Tracking Requested - why for this release]:
Mozmill is dead and no fix will land there. Instead we have to convert our Mozmill-CI jobs. I filed https://github.com/mozilla/mozmill-ci/issues/765 for that work.

This bug is clearly a wontfix.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
Unfortunately we can't set release tracking flags on github issues and this is a blocker for 46 atm (even though it should be fixed soon due to Henrik's great work).
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.