Disable SpiderMonkey support for E4X for-each

RESOLVED FIXED in Firefox 57

Status

()

defect
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: cpeterson, Assigned: emk)

Tracking

(Blocks 2 bugs, {dev-doc-complete, site-compat})

unspecified
mozilla57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 fixed)

Details

(Whiteboard: [DocArea=JS])

Attachments

(2 attachments)

No description provided.
This one is super-useful. I'd rather have it standardized, in a slightly improved form that allows custom classes to easily be iterated.
A slightly different form, |for (val of obj)|, got standardized.  To use it you define obj[@@iterator] as a function that returns an iterator object yielding values that are bound in sequence to val.

@@iterator is -- very shortly -- going to be Symbol.iterator.  Right now it's just "@@iterator", I think, as a temporary hack.  So enabling symbol support in releases, and making Symbol.iterator work, are prerequisites to using for-of on objects other than those that we've already made iterable.  Arrays are the most common already-iterable object right now.
Depends on: 918828
Keywords: dev-doc-needed
Whiteboard: [DocArea=JS]
Depends on: 1171509
Depends on: 1171586
Depends on: 1172536
Blocks: 1103158
Depends on: 1215965
Depends on: 1216775
Depends on: 1217038
Depends on: 1217072
Depends on: 1217077
Depends on: 1217082
Depends on: 1217093
Depends on: 1217315
Depends on: 1217316
Depends on: 1217318
Depends on: 1217422
Depends on: 1217423
Depends on: 1217424
Depends on: 1217981
Depends on: 1217982
Depends on: 1217983
Depends on: 1221634
Depends on: 1221637
Depends on: 1221638
Depends on: 1234048
Depends on: 1293205
Depends on: 1293305
Depends on: 1293669
Duplicate of this bug: 824289
current telemetry result

CONTENT
   | Nightly | Aurora  | Beta    | Release
---+---------+---------+---------+----------
45 |      1  |      0  |      0  |      1
46 |      0  |      1  |      2  |      0
47 |      0  |      1  |      1  |      0
48 |      2  |      1  |      2  |      1
49 |      8  |      1  |      0  |      2
50 |      1  |      1  |      1  |      -
51 |      3  |      7  |      -  |      -
52 |      0  |      -  |      -  |      -

ADDON
   | Nightly | Aurora  | Beta    | Release
---+---------+---------+---------+----------
45 | 133.27k | 645.85k | 230.41k | 649.69k
46 | 205.45k | 471.80k | 171.08k | 451.86k
47 | 192.48k | 279.69k | 157.39k | 658.98k
48 |  59.48k |  51.69k | 208.46k | 342.13k
49 |   2.88k |  82.57k | 118.06k | 422.39k
50 |   4.06k |  74.11k | 185.27k |      -
51 |   4.21k |  71.60k |      -  |      -
52 |   1.57k |      -  |      -  |      -


it's reducing on Nightly and aurora.
it we also observe reduction on beta and release in next some cycles, we could remove it.
Blocks: 1JS
CONTENT
    | nightly    | aurora     | beta       | release
----+------------+------------+------------+------------
 45 |          1 |          0 |          0 |         37
 46 |          0 |          1 |          2 |          6
 47 |          0 |          1 |          1 |          2
 48 |          2 |          1 |          2 |          9
 49 |          8 |          1 |          0 |          9
 50 |          1 |          1 |        121 |          5
 51 |          3 |          7 |          1 |          3
 52 |          0 |          2 |          0 |          0
 53 |          0 |          1 |          - |          0
 54 |          0 |          - |          - |          -
ADDONS
    | nightly    | aurora     | beta       | release
----+------------+------------+------------+------------
 45 |     138460 |     650814 |     235841 |     650429
 46 |     205489 |     471888 |     174660 |     453430
 47 |     192617 |     283759 |     157472 |     680933
 48 |      62149 |      51696 |     211752 |     408324
 49 |       3341 |      83641 |     119269 |     433545
 50 |       5024 |      74285 |     191778 |     514502
 51 |       5825 |      73602 |     265392 |     131381
 52 |       1657 |     120173 |      45066 |          -
 53 |        587 |      47502 |          - |          -
 54 |          0 |          - |          - |          -

(note: latest versions don't have enough data to compare)
CONTENT
    | nightly    | aurora     | beta       | release   
----+------------+------------+------------+------------
 45 |          1 |          0 |          0 |         37
 46 |          0 |          1 |          2 |          6
 47 |          0 |          1 |          1 |          2
 48 |          2 |          1 |          2 |          9
 49 |          8 |          1 |          0 |          9
 50 |          1 |          1 |        210 |          5
 51 |          3 |          7 |          1 |         19
 52 |          0 |          2 |          0 |         26
 53 |          0 |          2 |        108 |         11
 54 |          0 |          2 |          0 |          0
 55 |          0 |          0 |          0 |          -
 56 |          0 |          - |          - |          -
ADDONS
    | nightly    | aurora     | beta       | release   
----+------------+------------+------------+------------
 45 |     138460 |     650827 |     235841 |     650431
 46 |     205489 |     471902 |     174660 |     454734
 47 |     192617 |     283759 |     157473 |     688471
 48 |      62149 |      51732 |     212113 |     431219
 49 |       3567 |      83641 |     119573 |     434457
 50 |       5088 |      74294 |     191840 |     527190
 51 |       5825 |      73668 |     267455 |     253480
 52 |       1657 |     141589 |      91130 |     200836
 53 |        881 |      96421 |      93702 |     262834
 54 |          0 |     129100 |      89164 |      16238
 55 |          0 |         80 |       6027 |          -
 56 |          0 |          - |          - |          -

(note: latest versions don't have enough data to compare)
We don't have to care about add-ons anymore post 57.
(In reply to Masatoshi Kimura [:emk] from comment #8)
> We don't have to care about add-ons anymore post 57.

do "XPCOM extensions" include "add-on SDK extensions" here?
(In reply to Tooru Fujisawa [:arai] from comment #9)
> (In reply to Masatoshi Kimura [:emk] from comment #8)
> > We don't have to care about add-ons anymore post 57.
> 
> do "XPCOM extensions" include "add-on SDK extensions" here?

Yes. All non-WebExtensions add-ons will not be supported since 57. And WebExtensions have banned versioned JavaScript since day one.
Keywords: addon-compat
I believe content usage is enough low to kill this.
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED
Comment on attachment 8894188 [details]
Bug 1083470 - Disable E4X for-each in release.

https://reviewboard.mozilla.org/r/165288/#review170750

Based on low count in normal content and discontinuation of old-style addons, I can't see why not.
Attachment #8894188 - Flags: review?(luke) → review+
Pushed by VYV03354@nifty.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/179deaedc512
Disable E4X for-each in release. r=luke
https://hg.mozilla.org/mozilla-central/rev/179deaedc512
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Summary: Remove SpiderMonkey support for E4X for-each → Disable SpiderMonkey support for E4X for-each
Blocks: 1388317
You need to log in before you can comment on or make changes to this bug.