C-C TB. Configuration error. Cannot find project mail

RESOLVED DUPLICATE of bug 1254987

Status

Thunderbird
Build Config
--
blocker
RESOLVED DUPLICATE of bug 1254987
2 years ago
2 years ago

People

(Reporter: ISHIKAWA, Chiaki, Unassigned)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
I think this is a fairly recent build issue. I updated my source tree less than hour ago on local PC.
Then C-C TB configuration failed.

It worked for the last few days without a hitch.

---
client.mk:205: /NREF-COMM-CENTRAL/objdir-tb3/.mozconfig.mk: No such file or directory
mkdir -p '/NREF-COMM-CENTRAL/objdir-tb3/'
> /NREF-COMM-CENTRAL/objdir-tb3/.mozconfig.mk
Adding client.mk options from /NREF-COMM-CENTRAL/comm-central/mozconfig-tb3:
    AUTOCLOBBER=1
    MOZ_OBJDIR=/NREF-COMM-CENTRAL/objdir-tb3
    MOZ_CO_PROJECT=mail
    BUILD_OFFICIAL=1
    MOZILLA_OFFICIAL=1
    BUILD_MODULES=all
    MOZ_MAKE_FLAGS=-j1
    MOZ_MAKE_FLAGS=-s
    FOUND_MOZCONFIG := /NREF-COMM-CENTRAL/comm-central/mozconfig-tb3
make[1]: Entering directory '/NREF-COMM-CENTRAL/comm-central'
cd /NREF-COMM-CENTRAL/objdir-tb3
/NREF-COMM-CENTRAL/comm-central/configure
creating cache ./config.cache
Creating Python environment
New python executable in /NREF-COMM-CENTRAL/objdir-tb3/_virtualenv/bin/python2.7
Also creating executable in /NREF-COMM-CENTRAL/objdir-tb3/_virtualenv/bin/python
Installing setuptools, pip, wheel...done.
running build_ext
copying build/lib.linux-x86_64-2.7/psutil/_psutil_linux.so -> psutil
copying build/lib.linux-x86_64-2.7/psutil/_psutil_posix.so -> psutil

Reexecuting in the virtualenv
Adding configure options from /NREF-COMM-CENTRAL/comm-central/mozconfig-tb3
  --enable-application=mail
  --enable-gc-zeal
  --enable-debug-symbols=-gsplit-dwarf
  --disable-necko-wifi
  --enable-tests
  --disable-gstreamer
  --enable-debug
  --enable-shared
  --enable-official-branding
  --disable-libjpeg-turbo
  --with-system-ply
  --disable-necko-wifi
  --enable-valgrind
  --enable-optimize=-g -O0 -fno-omit-frame-pointer -freorder-blocks
  --disable-jemalloc
  --with-ccache=/usr/bin/ccache
  --disable-unified-compilation
  --enable-profiling
  --disable-install-strip
  --disable-crashreporter
  --disable-elf-hack
Cannot find project mail
*** Fix above errors and then restart with\
               "make -f client.mk build"
/NREF-COMM-CENTRAL/comm-central/client.mk:363: recipe for target 'configure' failed
make[1]: *** [configure] Error 1
make[1]: Leaving directory '/NREF-COMM-CENTRAL/comm-central'
client.mk:377: recipe for target '/NREF-COMM-CENTRAL/objdir-tb3/Makefile' failed
make: *** [/NREF-COMM-CENTRAL/objdir-tb3/Makefile] Error 2

real	0m2.026s
user	0m1.608s
sys	0m0.216s

date

---

I have no idea.But maybe 
"Reexecuting in the virtualenv"
may point to the culprit.

TIA

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1254987

Updated

2 years ago
Severity: normal → blocker
Keywords: regression
You need to log in before you can comment on or make changes to this bug.