Closed Bug 1255740 Opened 4 years ago Closed 2 years ago

Make Beta and Nightly of Firefox Desktop use different profile than Firefox release by default

Categories

(Toolkit :: Startup and Profile System, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1373244

People

(Reporter: xidorn, Unassigned)

References

(Blocks 1 open bug)

Details

It has been discussed over and over again in the mailing list. It seems that the benefit is pretty clear: user won't meet profile downgrade and lose data for helping us testing newer versions. This would also allow user to install more versions in parallel rather than just release and developer edition.

Moreover, I think we should give each try build a different default profile. But this could be discussed in other bugs.

The only remaining question is, what should we do for existing users of those channels.

If we can distinguish between newly-installed instance and upgraded instance, then we should probably migrate the previous profile for the latter.
(In reply to Xidorn Quan [:xidorn] (UTC+8) from comment #0)
> It has been discussed over and over again in the mailing list. It seems that
> the benefit is pretty clear: user won't meet profile downgrade and lose data
> for helping us testing newer versions.

But quite often when users have an issue on version X and we ask them to test on version Y, them having the issue depends on the profile they're using in version X... so I don't think that this would really change much, except introduce frustration because now users would have to jump through hoops to get the same profile to run in $otherbuild.

I think your analysis about the upsides with no consideration about the downsides is not a fair assessment. Previous discussions decided only to do something for devedition. If you think something has changed, or "just" that that discussion needs to be reconsidered, the mailing list would be the appropriate place to get that to happen - not filing a bug from a particular pov disregarding people who disagreed.
Component: General → Startup and Profile System
Product: Firefox → Toolkit
This was discussed here: https://groups.google.com/d/topic/mozilla.dev.platform.ux/RV01AFaozJQ/discussion (starts from my post and then ehsan's).

It seems to me no people involved in the discussion disagree with this proposal. There are only people strongly agreed with this, and people didn't express anything about this.

I pretty much believe it makes much more sense to allow people testing different versions in parallel, rather than testing different versions on the same profile. Personally I only install stable and devedition because they are independent. Before devedition released, I only used stable (and local build from mach, which has its own testing profile). If other versions won't conflict with each other, I'd be happy to install them as well. I think I'm not alone.
(In reply to Xidorn Quan [:xidorn] (UTC+8) from comment #2)
> This was discussed here:
> https://groups.google.com/d/topic/mozilla.dev.platform.ux/RV01AFaozJQ/
> discussion (starts from my post and then ehsan's).

I wasn't even aware dev.platform.ux existed, and it seems to only have done so since February of this year. Why wasn't this discussed on fx-dev? It clearly affects more than just the platform team, and isn't really related to platform UX. There was a discussion on fx-dev before we changed the devedition behaviour (which still has bugs like bug 1098986), and there was more opposition and discussion then: https://groups.google.com/forum/#!topic/firefox-dev/c2PyBpwWmgw .
Duplicate of this bug: 1265322
Blocks: 1280394
What is the process to more forward with this RFE? I work on increasing our Nightly users numbers to help improve quality and I get asked by new Nightly users everyday why it doesn't create its own profile like Dev Edition. To me this looks like a barrier to adoption for Nightly so I would like to know if a decision will be done on this one or not (the bug 1265322 which was made a duplicate of this one only dealt with Nightly, not Beta).
Not even me want to try Beta and Nightly due to this issue...
Should this bug be duped to bug 895030 ?
(In reply to Pascal Chevrel:pascalc from comment #7)
> Should this bug be duped to bug 895030 ?

I applaud the goals of getting more nightly and beta users who are not developers. (And I use nightly almost 24x7.)  It has a ton of (good?) discussion. (may also bring some baggage)  But unclear whether the goals are the same, eg bug 895030 comment 0 mentions developers, not users.  It also offers a specific solution right off the bat. I haven't read all of the rest of it to see to what extent either area evolved in discussion. 

I'm with Gijs and comment 3. Namely, this probably deservers some open discussion outside BMO. And perhaps UX is not the right place.

Note, as a bug triager and user of all the channels (except developer), I would not look upon favorably anything which cause me pain and substantially gets in the way of me bouncing between channels while *using the same profile*.


> the bug 1265322 which was made a duplicate of this one only dealt with Nightly, not Beta)

Sorry, that was me. If the two bugs are not likely to have the same solution then feel free to undupe.
any news for this? what is blocking this? is it that we dont know how to handle it, or is it that noone stepped up to take this bug?
(In reply to pvinis from comment #9)
> any news for this? what is blocking this? is it that we dont know how to
> handle it, or is it that noone stepped up to take this bug?

Pinging Dave as he was the last person to raise this in m.d.platform (thread may be useful reading anyway: https://groups.google.com/d/msg/mozilla.dev.platform/-caAmk_ijnY/nQcI87uHAwAJ ).
Flags: needinfo?(dtownsend)
Going to forward-dupe this to the bug where work will likely happen on this.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(dtownsend)
Resolution: --- → DUPLICATE
Duplicate of bug: 1373244
You need to log in before you can comment on or make changes to this bug.