Closed Bug 1098986 Opened 5 years ago Closed 6 months ago

Firefox Developer Edition ignores "Use the selected profile without asking at startup" option in Profile manager

Categories

(Firefox :: General, defect, P3)

35 Branch
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: moz_en-gb, Unassigned)

References

Details

If Aurora is going to continue to ignore the "Use the selected profile without asking at startup" option in the Choose User Profile dialog (see bug 1096314), you should probably remove it, or fix it, or something.
It works on everything apart from devedition. This risk was brought up in bug 1024110; I don't know how difficult it would be to address.
Component: Untriaged → General
This bug is a dupe of 1183152 (I'd change it myself, but I can't)
Confirmed for Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0

Expected behavior:
- User's profiles not be ignored as if they don't exist because of some botched naming scheme and selection routine
- User's preference for Firefox to use a certain profile not be ignored, just because the application wants one called "developer-edition-profile" (If I want profiles, I'll manually ask Firefox to make them. Otherwise, it needs to get out.)
- User receives feedback upon failure to load profile, instead of program assuming that the profile needs to be created.
- User's profile selection not be ignored in environments where multiple profiles exist
- Above all else, engage in gathering feedback instead of breaking usability for the user, since the application has such intolerable default behaviors and placements, and since most users will not know their profile name.

Actual behavior:
- Any time Firefox isn't certain of a profile's validity, whether because of an upgrade that broke something, or because it doesn't like that profile's name, (even though it made the profile) or because someone doesn't like puppies.
-Profiles are a wonderful concept, but they're Taco Bell without Charmin.

Your team is maintaining probably the most important application that most users interact with. Please don't break our relationship with it by just not asking questions. And for Pat's sake, please stop making profiles I don't bloody want and mangling the names with **** like "unicorn-edition-plus-with-a-free-puppy" I'm not using developer edition because of developing, but even if I was, you hate puppies, so I win.

Thanks to your mom for having you: (Accident or not)
And you for having me: (Not for dinner or for dinner)
Mrs. Ho
Duplicate of this bug: 1183152
See Also: → 1237520
This bug and Bug 1096923 combine in unfriendly ways if the "dev-edition-default" profile is renamed using about:profiles.

On restart, Developer Edition/Aurora will create a new "dev-edition-default" profile (due to Bug 1096923) and will always use it, ignoring the default selected by the user (due to this bug).

The work-around is to rename the newly-generated profile and then rename the desired profile back to "dev-edition-default".
(In reply to Andy from comment #5)

Thank you for the workaround - works for me, this has really bugged me for a long time and can't believe I didn't think of trying to rename my profile to dev-edition-default!
I filed another bug report, because I hadn't come across this one, i.e. I didn't know that the present, existing bug report contained the explanation for the general shambles that installing the developer edition had caused.

That this bug is *years* old strikes me as frankly, a slapping-oneself-in-one's-own-face level of stupidity.
Duplicate of this bug: 1388210
Hey Dolske. I noticed this hasn't been triaged and I'm concerned how it might affect a critical audience of ours (developers) so I thought I'd raise it as a potential bug to be triaged. Thanks!
Flags: needinfo?(dolske)
Dave: Is this something already on your radar for profile-per-channel?

Would also welcome suggestions on if there's a simple solution here (or not).
Flags: needinfo?(dolske) → needinfo?(dtownsend)
Priority: -- → P3
This should be fixed by bug 1474285
Depends on: 1474285
Flags: needinfo?(dtownsend)
> The work-around is to rename the newly-generated profile and then rename the desired profile back to "dev-edition-default".

Another work-around I didn't consider is to *not* check the "Always start with the selected profile" checkbox: each time I start up, I can just reselect the default profile which is better than having to manually `firefox -p`.
Work around:

In %APPDATA%\Mozilla\Firefox create a file called "ignore-dev-edition-profile" without any extension

If "ignore-dev-edition-profile" exist it use the default profile from profiles.ini and proceed as usual

This worked for me!!!

This should be fixed.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED

Thanks!!!

You need to log in before you can comment on or make changes to this bug.