All users were logged out of Bugzilla on October 13th, 2018

Since version 45 saved passwords are not accessible (NS_ERROR_FAILURE) [nsIPK11Token.initPassword] crypto-SDR.js

RESOLVED INCOMPLETE

Status

()

P1
normal
RESOLVED INCOMPLETE
3 years ago
7 days ago

People

(Reporter: Barbara.Fischer-Bossert, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160303134406

Steps to reproduce:

I updated firefox from version 44.02 to 45.0. I opened the web site of my email provider and wondered why I was not asked for my master password. Furthermore, my username and my password were not inserted in their respective fields. I searched in Firefox options for my passwords, and the list was empty.
I reverted the update back to version 44.02 - and my passwords were there again. I used the Password Exporter plugin to export them. Again I installed version 45.0, and again my passwords were missing. The Password Exporter plugin was displayed as functional, and so I tried to import the passwords from the file. This blocked the working of the complete Firefox, and had to kill it via Task Manager.


Actual results:

After Update to Firefox 45.0 saved passwords are no more accessible. The Master Password is displayed as not existing and cannot be set again. There is no question to save passwords. Password Exporter plugin does not work anymore.


Expected results:

Master Password and saved passwords should be known, and there should be an option to save passwords.
(Reporter)

Updated

3 years ago
Severity: normal → blocker
Component: Untriaged → Security
Keywords: common-issue?
OS: Unspecified → Windows 7
Priority: -- → P1
Hardware: Unspecified → x86_64
Whiteboard: No passwords in Firefox 45.0

Updated

3 years ago
Severity: blocker → normal
Component: Security → Password Manager
Keywords: common-issue?
Priority: P1 → --
Product: Firefox → Toolkit
Whiteboard: No passwords in Firefox 45.0
Hello, I haven't seen any other reports of this so I suspect there's an issue related to your profile e.g. incompatible extension. Can you see if the problem hapeen in safe mode of 45? https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode
Flags: needinfo?(Barbara.Fischer-Bossert)

Comment 2

3 years ago
I am a linux user and am able to reproduce this issue in Xbuntu 15.10 with FF 45 as well as Fedora 23 and FF 45.

The auto-fill parts for the saved passwords still function, you just cannot access the saved passwords in the Security section.

The Fedora install is fresh this week and added to my FF sync account.  I just used this install to login with my github account stored in FF's saved passwords to comment so I know the passwords are stored and accessible EXCEPT from the actual Preferences => Security => Saved Passwords section.

Let me know what I can provide to confirm this bug.
Hi PresGas,

Did you try safe mode like I suggested in comment 1?

Can you please enable debug logging by following the instructions at https://wiki.mozilla.org/Toolkit:Password_Manager/Debugging?
Perform the following steps:
* Clear your Browser Console 
* Open the Save Logins page in Preferences/Options
* Now in another tab visit GitHub's login page (logout if you are already logged in)
* Copy and paste the Browser Console output into a new attachment on this bug using this page: https://bugzilla.mozilla.org/attachment.cgi?bugid=1255992&action=enter No passwords should appear in the logs, maybe usernames.

Confirm that the Github password was auto-filled.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Priority: -- → P1
Hardware: x86_64 → All
Flags: needinfo?(PresGas)

Comment 4

3 years ago
I've the same issue with firefox 45.0 on several linux systems with different profiles.  I can not use the password manager from "Preferences->Security->Saved Logins..." nor with the addon "save Password Editor" nor with chrome://passwordmgr/content/passwordManager.xul ... 

I can export my passwords with the addon "Password Exporter" and I can use them after provide my master password.

As I have to replace a expired password for a domain here I'd like to use a password manger to find and replace all occurences of the old password with the new password.

Comment 5

3 years ago
OK ... after some debugging I've detected the addon "Master Password+" as possible cause of not showing the password entries here.  That is that it had looked like not providing a master password.  After this idea  I've looked at https://addons.mozilla.org/en-US/firefox/addon/master-password/ and seen the reports there so I've simply restarted the firefox session here.  And now it works at least here.  Don't know if it will do on my other systems but I guess it does.

Comment 6

3 years ago
I confirm  Dr. Werner Fink the issue with "Master Password+".  I forgot I had it installed as I removed my master password.  I disabled this plug-in and this fixed the issue.
Flags: needinfo?(PresGas)

Comment 7

3 years ago
Master Password+ add-on has been updated yesterday, so it's probably fixed now.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

3 years ago
I don't use Master Password so that  cannot be the only cause of this malfunction


#
Flags: needinfo?(Barbara.Fischer-Bossert)

Comment 9

3 years ago
OK ... sorry about that. As I'm not able to repoen this bug you might do this. Hopefully the reporter is allowed to do this.

Updated

3 years ago
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 10

3 years ago
I reopen it but you have to test 2 things that you didn't do: safe mode and a new profile.
1) https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
2) https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

For testing the new profile, copy and export from your current profile both files key3.db & logins.json.
(Reporter)

Comment 11

3 years ago
For a short time I thought the problem was solved with version 45.01. But this version immediately began to download and install version 45.02 (which identifies itself as version 45.01, too) and the problem returned again.
(Reporter)

Comment 12

3 years ago
Safe mode did not solve the problem, either

Comment 13

3 years ago
And a new profile with your imported passwords? Please, answer the questions we ask.
(Reporter)

Comment 14

3 years ago
I created a new profile and imported my passwords (key3.db and login.json). Same procedure as before: I could not see any password, the master password was not there, either, and I could not set the master password (the dialog opened, and I could fiil it in, but after pressing enter I got an error message like "master password setting failed"). The same with a complete naked profile: It did not ask if I want to save my passwords, and it accepted no master password.

Comment 15

3 years ago
Are you using an external application to manage your passwords like LastPass or a service provided by your antivirus?
(Reporter)

Comment 16

3 years ago
none of them - not on this computer. On another one where i did not yet update Firefox I am using KeePass. With this experience I do not even dare to update.
Can you attach the about:support data from safe mode (after confirming your passwords are missing):
1) Type about:support in the address bar of a tab and hit enter
2) Click the "Copy text to clipboard" button
3) Load https://bugzilla.mozilla.org/attachment.cgi?bugid=1255992&action=enter and paste the text in the big textarea (you might need to click "paste text as attachment" to toggle from the file picker to pasting text.
4) Submit the attachment

Thanks
Flags: needinfo?(Barbara.Fischer-Bossert)
(Reporter)

Comment 18

3 years ago
Created attachment 8735108 [details]
contents of about:support as requested (in German)

Comment 19

3 years ago
Could you test:
1) Create a new profile
2) Set a simple master password like QWERTY
3) Log in a website like https://bugzilla.mozilla.org/ and save the login/password
4) Go to about:preferences#security and display the password list

Does the master password dialog box appear? Do you see the login/password saved in the password manager?
(Reporter)

Comment 20

3 years ago
As I said before it is not possible to set a msster password even in a ew profile. The dialog appears but setting itsel fails.
Flags: needinfo?(Barbara.Fischer-Bossert)

Comment 21

3 years ago
Do you have any error message in the browser console (Crtl+Maj+J) when it fails?
(Reporter)

Comment 22

3 years ago
These are all error messages in the browser console:

Could not read chrome manifest 'file:///C:/Program%20Files/Mozilla%20Firefox/chrome.manifest'.
While creating services from category 'profile-after-change', could not create service for entry 'Sapi Speech Synth', contract ID '@mozilla.org/synthsapi;1'
NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIPK11Token.initPassword] crypto-SDR.js:66:0
Error: Initialization failed storage-json.js:90:13
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "Initialization failed" {file: "resource://gre/components/storage-json.js" line: 90}]'[JavaScript Error: "Initialization failed" {file: "resource://gre/components/storage-json.js" line: 90}]' when calling method: [nsILoginManagerStorage::initialize] nsLoginManager.js:125:0
[Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: resource://gre/modules/XPCOMUtils.jsm :: XPCU_serviceLambda :: line 230"  data: no] Promise-backend.js:936:0
1459147498854	Services.HealthReport.HealthReporter	WARN	Saved state file does not exist.
Services.logins is undefined LoginManagerParent.jsm:610:0
Error: createFromField requires a password or username field in a document LoginManagerContent.jsm:1329:1
Services.logins is undefined LoginManagerParent.jsm:610:0
Tastenereignis ist in manchen Tastaturlayouts nicht verfügbar: Taste="c" Modifikatoren="accel,alt" browser.xul
Tastenereignis ist in manchen Tastaturlayouts nicht verfügbar: Taste="i" Modifikatoren="accel,alt,shift" browser.xul
Services.logins is undefined
(Reporter)

Comment 23

3 years ago
Now I saved all settings and plugins to another directory and deinstalled FF completely. I deleted all files in \user\<username>\AppData\Local\Mozilla\Firefox\ and \user\<username>\AppData\Roaming\Mozilla\Firefox\. I even tried to cleanse the registry. Then I restarted the computer and setup  FF anew. The first I did as it started up with an empty profile was to set a Master Password. But again it did not work - it said, "there is no Master Password" and "you cannot use one". These are the error messages I got in the browser consle:

Error: createFromField requires a password or username field in a document  LoginManagerContent.jsm:1329:1
Services.logins is undefined                                                LoginManagerParent.jsm:610:0
Status: REOPENED → NEW
Summary: in version 45 saved passwords are no more accessible, password exporter is not working anymore → Since version 45 saved passwords are not accessible (NS_ERROR_FAILURE) [nsIPK11Token.initPassword] crypto-SDR.js
Whiteboard: [DUPEME]
Status: NEW → RESOLVED
Last Resolved: 3 years ago7 days ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.