Fix Pocket after deprecating API from ioservice

RESOLVED FIXED in Firefox 48

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: ckerschb, Assigned: ckerschb)

Tracking

unspecified
mozilla48
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox48 fixed)

Details

Attachments

(1 attachment)

No description provided.
Assignee: nobody → mozilla
Blocks: 1254752
Status: NEW → ASSIGNED
I haven't realized that this.chromeURL is in fact a string a not an nsIURI. I verified that pocket works correctly again.
Attachment #8729886 - Flags: review?(mixedpuppy)
Comment on attachment 8729886 [details] [diff] [review]
bug_1256050_fix_pocket_after_deprecating_API_ioservice.patch

r+ assuming it is working correctly.
Attachment #8729886 - Flags: review?(mixedpuppy) → review+
Can we get a test for this?
Flags: needinfo?(mozilla)
Flags: in-testsuite?
(In reply to Ryan VanderMeulen [:RyanVM] from comment #3)
> Can we get a test for this?

Shane, it was quite surprising to me as well that we don't have an automated test for Pocket. Any chance you are willing to add one?
Flags: needinfo?(mozilla) → needinfo?(mixedpuppy)
Duplicate of this bug: 1256087
(In reply to Christoph Kerschbaumer [:ckerschb] from comment #5)
> (In reply to Ryan VanderMeulen [:RyanVM] from comment #3)
> > Can we get a test for this?
> 
> Shane, it was quite surprising to me as well that we don't have an automated
> test for Pocket. Any chance you are willing to add one?

That is not a simple process.  bug 1235627
Flags: needinfo?(mixedpuppy)
https://hg.mozilla.org/mozilla-central/rev/f31e566af61c
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Ryan, Shane, can we add some kind of test for Pocket? It's a button on the in the right corner on the main user interface of Firefox. I am sorry that I broke it, but we should have at least some kind of test that that is not going to happen again.
Flags: needinfo?(ryanvm)
Flags: needinfo?(mixedpuppy)
per comment 7 need to address bug 1235627
Flags: needinfo?(mixedpuppy)
Flags: needinfo?(ryanvm)
You need to log in before you can comment on or make changes to this bug.