Closed Bug 1256582 Opened 5 years ago Closed 4 years ago

js/src/threading/posix/Mutex.cpp:43:3: error: static assertion failed: platformData_ is too small on Linux/aarch64

Categories

(Core :: JavaScript Engine, defect)

ARM
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1257019
Tracking Status
firefox48 --- affected

People

(Reporter: m_kato, Assigned: terrence)

References

Details

Attachments

(1 file)

When building SpiderMonkey for Linux/aarch64, the following build error occurs.

 0:03.50B /hg/mozilla-central/js/src/threading/posix/Mutex.cpp:43:3: error: static assertion failed: platformData_ is too small
 0:03.50B    static_assert(sizeof(platformData_) >= sizeof(PlatformData),
 0:03.50B    ^
 0:03.50B
 0:03.50B In the directory  /hg/mozilla-central/obj-aarch64-linux-gnu/js/src
 0:03.50B The following command failed to execute properly:
 0:03.50B /usr/bin/ccache aarch64-linux-gnu-g++ -o Mutex.o -c -I/hg/mozilla-central/obj-aarch64-linux-gnu/dist/system_wrappers -include /hg/mozilla-central/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DENABLE_BINARYDATA -DENABLE_SIMD -DENABLE_SHARED_ARRAY_BUFFER -DEXPORT_JS_API -DJS_HAS_CTYPES -DDLL_PREFIX="lib" -DDLL_SUFFIX=".so" -DFFI_BUILDING -I/hg/mozilla-central/js/src -I/hg/mozilla-central/obj-aarch64-linux-gnu/js/src -I/hg/mozilla-central/obj-aarch64-linux-gnu/js/src/ctypes/libffi/include -I/hg/mozilla-central/intl/icu/source/common -I/hg/mozilla-central/intl/icu/source/i18n -I/hg/mozilla-central/obj-aarch64-linux-gnu/dist/include -I/hg/mozilla-central/obj-aarch64-linux-gnu/dist/include/nspr -fPIC -DMOZILLA_CLIENT -include /hg/mozilla-central/obj-aarch64-linux-gnu/js/src/js-confdefs.h -MD -MP -MF .deps/Mutex.o.pp -Wall -Wc++11-compat -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wwrite-strings -Wunreachable-code -Wno-invalid-offsetof -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -fno-rtti -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe -g -freorder-blocks -O3 -fomit-frame-pointer /hg/mozilla-central/js/src/threading/posix/Mutex.cpp
 0:03.50B /hg/mozilla-central/config/rules.mk:963: recipe for target 'Mutex.o' failed


When I look bits/pthreadtypes.h on Linux/aarch64 (Ubuntu 15.10), sizeof(pthread_mutex_t) is the following.
...
#define __SIZEOF_PTHREAD_MUTEX_T       48
...
Thanks for the heads up! This should fix it until we can make HAVE_PTHREADS available to spidermonkey.
Assignee: nobody → terrence
Status: NEW → ASSIGNED
Attachment #8730774 - Flags: review?(m_kato)
Attachment #8730774 - Flags: review?(m_kato) → review+
Nick fixed this implicitly when he added a move constructor in bug 1257019. The definition are all using the pthread_mutex_t defined in <pthreads.h>. Sorry I let this drop off my radar; please re-open if the code on tip does not work for some reason.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1257019
You need to log in before you can comment on or make changes to this bug.