Closed Bug 1257019 Opened 4 years ago Closed 4 years ago

Add move construction to js::Mutex<T>

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla48
Tracking Status
firefox48 --- fixed

People

(Reporter: fitzgen, Assigned: fitzgen)

References

Details

Attachments

(1 file, 3 obsolete files)

No description provided.
Attachment #8730982 - Flags: review?(terrence)
Assignee: nobody → nfitzgerald
Status: NEW → ASSIGNED
Comment on attachment 8730982 [details] [diff] [review]
Add move construction to js::Mutex<T>

Review of attachment 8730982 [details] [diff] [review]:
-----------------------------------------------------------------

Please add tests covering the new functionality to jsapi-tests/testThreadingMutex.cpp.
Attachment #8730982 - Flags: review?(terrence) → review+
Attachment #8730982 - Attachment is obsolete: true
Attachment #8731877 - Attachment is obsolete: true
No, that wasn't your try push, that was four meaningless jobs which stayed tier-1 while RyanVM accidentally made everything that matters tier-3 for a while. Your try push would be https://treeherder.mozilla.org/#/jobs?repo=try&revision=f48510ffeb4a&filter-tier=1&filter-tier=2&filter-tier=3&selectedJob=18237582

Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/b0e2c28119d8
Attachment #8731883 - Attachment is obsolete: true
Much better!
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d5e77c8d64c9
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Duplicate of this bug: 1256713
Duplicate of this bug: 1256582
Blocks: 1333429
You need to log in before you can comment on or make changes to this bug.