Closed Bug 1256713 Opened 5 years ago Closed 4 years ago

Make HAVE_PTHREADS available to SpiderMonkey and use it to simplify Threads platform data definitions

Categories

(Core :: JavaScript: GC, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1257019
Tracking Status
firefox48 --- affected

People

(Reporter: terrence, Assigned: terrence)

References

Details

We are currently using over-large sizes on linux and "other" in order to support as broad a range of platforms and architectures as possible. We should instead be detecting pthread.h as part of configuration and using the platform correct size, at least where such makes sense.
Glandium told me to just use XP_WIN rather than fiddling with HAVE_PTHREADS, so that's what I'm going to do.
This was totally obsoleted when Nick added a move constructor.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1257019
You need to log in before you can comment on or make changes to this bug.