Middle mouse click on history item would not open

VERIFIED FIXED in Firefox 47

Status

()

defect
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: alice0775, Assigned: dao)

Tracking

({regression})

48 Branch
Firefox 49
Unspecified
Windows 7
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox46 unaffected, firefox47+ verified, firefox48+ verified, firefox49 verified)

Details

Attachments

(2 attachments)

[Tracking Requested - why for this release]: regression


Reproducible: always

Steps to reproduce:
1. Open hamburger menu
2. Click History icon
3. Middle mouse click on history item

Actual results:
Nothing happens

Expected results:
The history item should be opened in new tab
Flags: needinfo?(mak77)
Flags: needinfo?(dao)
well, we also need middle click working for recent bookmarks, so let's use this for both.
Flags: needinfo?(mak77)
Recent regression in 47, tracked 47+
Duplicate of this bug: 1250493
Assignee: nobody → dao+bmo
Flags: needinfo?(dao+bmo)
Attachment #8756263 - Flags: review?(mak77) → review+
Posted patch patchSplinter Review
I believe bug 1248267 fixed this for recent bookmarks.
Attachment #8756263 - Flags: review?(mak77)
Blocks: 1275793
https://hg.mozilla.org/mozilla-central/rev/5444f0c1e330
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 49
Approval Request Comment
[Feature/regressing bug #]: bug 1249473
[User impact if declined]: see comment 0 (only history widget items are affected, the recent bookmarks list isn't on beta / aurora)
[Describe test coverage new/current, TreeHerder]: no coverage
[Risks and why]: trivial fix, low risk
[String/UUID change made/needed]: none
Attachment #8757254 - Flags: approval-mozilla-beta?
Attachment #8757254 - Flags: approval-mozilla-aurora?
Comment on attachment 8757254 [details] [diff] [review]
patch for uplift

Recent regression, taking it
Attachment #8757254 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
This is marked as a regression in 47; can we uplift to beta?
Flags: needinfo?(rkothari)
(In reply to Andrew Overholt [:overholt] from comment #12)
> This is marked as a regression in 47; can we uplift to beta?

Yes, this seems like a low-risk fix and recent regression. I will take it in RC1.
Flags: needinfo?(rkothari)
Comment on attachment 8757254 [details] [diff] [review]
patch for uplift

This is a recent and very visible end-user regression, let's uplift to Beta47
Attachment #8757254 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
Reproduced on Nightly 2016-03-23.
Verified fixed FX 47 RC build 3, 48.0a2 (2016-06-05), 49.0a1 (2016-06-05) Win 7
You need to log in before you can comment on or make changes to this bug.