Closed Bug 1257396 Opened 6 years ago Closed 6 years ago

same-line diff highlighting draws is overemphasized

Categories

(MozReview Graveyard :: Review Board: User Interface, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1224733

People

(Reporter: glob, Unassigned)

Details

Attachments

(1 file)

<dbaron> so something that's really started to bug me about the MozReview UI:
<dbaron> https://reviewboard.mozilla.org/r/39663/diff/3#index_header
<dbaron> on some lines, it decides there's a small change that it wants to explain to me clearly, because just a specific piece of the line was added/removed
<dbaron> like the "chrome://mochikit/content/" removed in test_additional_sheets.html
<dbaron> so it's easy to start scanning for those bits to look for the added/removed bits
<dbaron> except the lines with that stuff highlighted
<dbaron> aren't at all different from the lines that have arbitrary changes without stuff highlighted
<dbaron> so anytime I attempt to scan that way, I end up missing changes
<dbaron> in effect, the UI tries to trick me into ignoring the actually-substantive changes
<mcote> dbaron: hm yeah that highlighting does seem overemphasized sometimes
<glob> i wonder if an outline would be better

the attached screenshot uses a css outline (not border) instead of a background colour.
.sidebyside tbody.replace .hl {
  outline: 1px solid #a7aa1f;
}
I think this is essentially the same as bug 1224733 (although the proposed solution is a bit different).
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1224733
You need to log in before you can comment on or make changes to this bug.