Context is shown in Conversation Window even though guest did not join the room

RESOLVED WONTFIX

Status

Hello (Loop)
Client
--
minor
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox45 affected, firefox46 affected, firefox47 affected, firefox48 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8732140 [details]
Screencast showing the issue

[Affected versions]:
- Firefox 45.0.1 (with hello version 1.1.14)
- Firefox 46 beta 2 (with hello version 1.1.12)
- Latest Developer Edition (hello version 1.2)
- Latest Nightly (hello version 1.2)

[Affected platforms]:
- Ubuntu 14.04 32-bit
- Mac OS X 10.11.1
- Windows 10 64-bit
- Windows 7 64-bit

[Steps to reproduce]:
1. Open Firefox
2. Visit a webpage
3. Start a call
4. Click stop sharing
5. Click resume sharing

[Expected result]:
- Nothing happens in Conversation window

[Actual result]:
- Context appears in Conversation window

[Regression range]:
- This is not a regression range, it was introduced with the new UI design from conversation window.
- If I install older versions of the add-on on Nightly, hello will be broken so I’m unable to provide a regression through add-on versions. (I could install 0.2 though)

[Additional notes]:
- Using version 0.2 of the add-on, the issue is not reproducible.
It's intentional that activity shows up before another person had joined (this gives some indication of what another person would see after they have joined)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.