The icon is not displayed for some add-ons

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: vasilica.mihasca, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox45 unaffected, firefox46 unaffected, firefox47 affected, firefox48 affected)

Details

[Affected versions]:
Firefox 48.0a1 (2016-03-16)
Firefox 47.0a2 (2016-03-18)

[Affected platforms]:
Windows 10 64-bit
Ubuntu 14.04 32-bit
Mac OS 10.11

[Steps to reproduce]:
1.Launch Firefox with clean profile.
2.Navigate to https://addons.mozilla.org/en-US/firefox/addon/video-downloadhelper/?src=cb-dl-users
3.Install the add-on.

[Expected Results]:
The add-on icon is successfully displayed in toolbar/customization palette/panel menu.

[Actual Results]:
- The add-on icon does not appear in toolbar/customization palette/panel menu. 
- See screenshot: http://i.imgur.com/TupOXCm.jpg 
- The following errors are thrown in Browser Console:
downloadhelper:Object { , 5 more… } runner.js:166
downloadhelper:Object { , 5 more… } Promise-backend.js:940


[Regression range]:
(m-c)
Last good revision: 918df3a0bc1c4d07299e4f66274a7da923534577 (2016-02-26)
First bad revision: 5e0140b6d11821e0c2a2de25bc5431783f03380a (2016-02-27)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=918df3a0bc1c4d07299e4f66274a7da923534577&tochange=5e0140b6d11821e0c2a2de25bc5431783f03380a

(m-i)
Last good revision: 918df3a0bc1c4d07299e4f66274a7da923534577
First bad revision: 07438c9bfc83970721893d77a6daf1bc0c5fd72d
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=918df3a0bc1c4d07299e4f66274a7da923534577&tochange=07438c9bfc83970721893d77a6daf1bc0c5fd72d

[Additional notes]:
- This issue also reproduces for: Firebug, Element Hiding Helper for Adblock Plus, YouTube mp3, anonymoX, ProxTube - Unblock YouTube
- I suspect that this issue might be specific for “no restart” add-ons.
Video download helper on 47 was broken by the API change in bug 1245184, we should probably get the add-on author to update. That is unlikely to affect other restartless add-ons though. On 48 many restartless add-ons are currently broken by bug 1257111. Do the other add-ons you mention also fail in 47?
Blocks: 1245184
Adding VDH dev.

Comment 3

2 years ago
Yeah, bug 1245184 hurts :)

Version 5.5.0a17 https://addons.mozilla.org/en-US/firefox/addon/video-downloadhelper/versions/5.5.0a17 has a workaround for this issue on 47.

I didn't know about bug 1257111 , i'll investigate and make sure version 5.5.0 (soon to be submitted) works on 48.
(In reply to Dave Townsend [:mossop] from comment #1)
> Video download helper on 47 was broken by the API change in bug 1245184, we
> should probably get the add-on author to update. That is unlikely to affect
> other restartless add-ons though. On 48 many restartless add-ons are
> currently broken by bug 1257111. Do the other add-ons you mention also fail
> in 47?

This issue is also reproducible on Firefox 47.0a2 while installing the following add-ons:
- Element Hiding Helper for Adblock Plus
- Adblock Edge
- YouTube mp3 
- Download YouTube Videos as MP4
- Reddit Enhancement Suite

But, this time, I did no longer encountered this issue for Firebug, ProxTube - Unblock YouTube and anonymoX. The icon was successfully displayed using Firefox 48.0a1 (2016-03-20) and Firefox 47 (2016-03-20).

Comment 5

2 years ago
we undid the API change that caused this original bug - can you reproduce with latest Nightly?
Flags: needinfo?(vasilica.mihasca)
This issue seems to be fixed on Firefox 49.0a1 (2016-05-04) and Firefox 48.0a2 (2016-05-05) under Windows 10 64-bit and Mac OS X 10.11.

But, I’ve noticed that the Adblock Edge icon (https://addons.mozilla.org/en-US/firefox/addon/adblock-edge/?src=ss) is not displayed by default in toolbar and it doesn’t appear selecting “Show in toolbar” option from the add-on details tab http://screencast.com/t/8XxX4H4lVm 

Any thoughts about this? Should I file a separate bug?
Flags: needinfo?(vasilica.mihasca) → needinfo?(sescalante)

Comment 7

2 years ago
yes please file a separate bug for the Ad Block issue you saw....
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(sescalante) → needinfo?(vasilica.mihasca)
Resolution: --- → WORKSFORME
(In reply to :shell escalante from comment #7)
> yes please file a separate bug for the Ad Block issue you saw....

Filed Bug 1272370.
Flags: needinfo?(vasilica.mihasca)
You need to log in before you can comment on or make changes to this bug.