Closed Bug 1258161 Opened 4 years ago Closed 4 years ago

XML parsing error in omni.ja!/chrome/toolkit/content/global/netError.xhtml

Categories

(Toolkit :: Safe Browsing, defect)

47 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla48
Tracking Status
firefox46 --- unaffected
firefox47 --- fixed
firefox48 --- fixed

People

(Reporter: benl234, Assigned: philip.chee)

References

()

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0 SeaMonkey/2.40
Build ID: 20160120202951

Steps to reproduce:

Started Seamonkey 2.44a2 and tried to navigate to any URL.

Also happens on initial attempt to show http://www.seamonkey-project.org/start/



Actual results:

No page is displayed, instead this is shown:

XML Parsing Error: undefined entity Location: jar:file:///C:/Users/[user name]/AppData/Local/SeaMonkeyTest/omni.ja!/chrome/toolkit/content/global/netError.xhtml Line Number 296, Column 36:
        <h1 id="et_malwareBlocked">&malwareBlocked.title;</h1>
-----------------------------------^


Expected results:

Page at URL should be displayed.

User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0 SeaMonkey/2.44a2

Build identifier: 20160309193908
Ok, so this is not that bad. I hadn't properly set the firewall to let Seamonkey through.

But it's still a little bug.

So, for the steps to reproduce section:

Please replace "any URL" with "any unreachable URL"

and for the "expected results" section:

please delete "Page at URL should be displayed."

and replace with "'Failed to Connect' page should be displayed."

Sorry about that.
Windows 7, Seamonkey 2.45a1, build 20160308001946

I get the same error but only on some sites. I think I was supposed to get some kind of DNS error coming back to the browser, since other browsers (e.g. Chrome) also get an error on the same URLs but indicate a DNS problem of some sort. However, I think my particular error might actually have been caused by a blacklisted IP address.

Regardless, as benl said, the XML error should not occur and a more meaningful error message should display.
Confirmed using Adrians unofficial 2.44a2 Windows x64 en-US build

>> User agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0 >> SeaMonkey/2.44a2
>> Build identifier: 20160309193908

and private 2.45a1 Windows x64 en-US VS2015 build

>> User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0 >> SeaMonkey/2.45a1
>> Build identifier: 20160325110550

You can force showing the error if just enter an invalid url like about:lalal

Does not occur in 2.43. 

I am unsure what changed in the backend. Seamonkey does not have a netError.dtd which together with another change might have triggered this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: XML parsing error in omni.ja!/chrome/toolkit/content/global/netError.xhtml , won't load any pages → XML parsing error in omni.ja!/chrome/toolkit/content/global/netError.xhtml
Duplicate of this bug: 1259138
Component: General → Safe Browsing
Product: SeaMonkey → Toolkit
Version: SeaMonkey 2.44 Branch → 47 Branch
Keywords: regression
These strings are actually used. hint DXR hint MXR hint hint nudge nudge.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #8734773 - Flags: review?(past)
Are the removed strings in Big 1245992 still needed elsewhere or could they be just removed from netError.xhtml? The Safebrowsing feature itself in Firefox and Seamonkey doesn't need them.
Oops make that Bug 1245992
Comment on attachment 8734773 [details] [diff] [review]
Restore removed strings that are actually used.

(In reply to Frank-Rainer Grahl from comment #6)
> Are the removed strings in Bug 1245992 still needed elsewhere or could they
> be just removed from netError.xhtml? The Safebrowsing feature itself in
> Firefox and Seamonkey doesn't need them.
Good question! New patch comming up
Attachment #8734773 - Flags: review?(past) → review-
Building now.
Attachment #8734773 - Attachment is obsolete: true
Revised patch works for me. Did the same in parallel after writing the comment to check it out. 

>> VS2015 x64 en-US build
>> User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0 SeaMonkey/2.45a1
Attachment #8734824 - Flags: review?(past)
Comment on attachment 8734824 [details] [diff] [review]
Patch remove unused strings from docshell/resources/content/netError.xhtml

Review of attachment 8734824 [details] [diff] [review]:
-----------------------------------------------------------------

Firefox doesn't use this file, so our tests didn't catch this. Thanks!
Attachment #8734824 - Flags: review?(past) → review+
https://hg.mozilla.org/mozilla-central/rev/2a8ca5caae8e
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Duplicate of this bug: 1261556
REPRODUCIBLE with  English SeaMonkey 2.45a1  (Windows NT 6.1; WOW64; rv:48.0)  Gecko/20100101 Firefox/48.0 Build 20160308001946  (Default Classic Theme)  on German WIN7 64bit.

I think we urgently need some backports for SeaMonkey
Only m-a is still affected.
Comment on attachment 8734824 [details] [diff] [review]
Patch remove unused strings from docshell/resources/content/netError.xhtml

Approval Request Comment
[Feature/regressing bug #]: Bug 1259922 

[User impact if declined]: Visiting any invalid URL will result in XML Parsing Error instead of the proper error page.

[Describe test coverage new/current, TreeHerder]: Baked on mozilla-central.

[Risks and why]: No risk. Fix bustage caused by Bug 1259922

[String/UUID change made/needed]: None.
Attachment #8734824 - Flags: approval-mozilla-aurora?
(In reply to Frank-Rainer Grahl from comment #16)
> Only m-a is still affected.
> status-firefox47: --- → affected
Firefox has completely forked netError.* files. Which is why they didn't realize that they were breaking other consumers in Bug 1259922.
Hi Panos, can I get a second opinion from you on whether this fix needs to be uplifted to Aurora 47 or should we let it just ride the trains? Thanks!
Flags: needinfo?(past)
I think it's pretty safe to uplift this patch. As comment 18 says, it won't affect Firefox at all.
Flags: needinfo?(past)
Bug 1259922 landed in (thunderbird) 48. How would that cause a regression in Firefox 47?  Are our releases not in sync now?

Marking 46 as unaffected.
Flags: needinfo?(philip.chee)
Firefox 47 itself is not affected. It does not use the file. Just the mozilla-aurora tree which is at 47 contains this bug and there is no flag for the tree itself. Seamonkey 2.44 in c-a is affected and needs this fix because it does still use netErrror.xhtml from m-a.
Flags: needinfo?(philip.chee)
1. mozilla-aurora contains code some of which is used by Firefox, and some of it isn't.
2. The confusion is that there are no tracking flags for gecko-47 only for firefox-47.
3. This uplift request is for Gecko code that lives in mozilla-* but isn't used by Firefox-*
4. This code *is* used by SeaMonkey however so we need to unbreak SeaMonkey by uplifting to mozilla-aurora.
5. Thunderbird is ... confusing. They have *partially* forked some of the netError.* files. I suggest you ignore what is happening to the Thunderbird part of the comm-* trees as far as this patch is conserned.
Flags: needinfo?(lhenry)
Comment on attachment 8734824 [details] [diff] [review]
Patch remove unused strings from docshell/resources/content/netError.xhtml

NPOTB (thanks everyone who helped clarify), Aurora47+
Attachment #8734824 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: needinfo?(lhenry)
Duplicate of this bug: 1270512
See "Bug 1283423 - Getting this again: XML Parsing Error: undefined entity Location: ... "

Fix incomplete? Not yet pulled to SM? Something else?
See Also: → 1283423
Duplicate of this bug: 1283423
You need to log in before you can comment on or make changes to this bug.