If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Build error] recipe for target 'out/target/product/amami/obj/DATA/gecko_intermediates/gecko' failed

RESOLVED DUPLICATE of bug 1258034

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 1258034
2 years ago
2 years ago

People

(Reporter: lapineige, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.2357.125 Safari/537.36

Steps to reproduce:

[Kubuntu 15.04 64 bits]

After setup to build for anami, I used ./build.sh -j1.

./repo sync was done just before build and setup.


Actual results:

Build failed with this message:
In the directory  /home/lapineige/B2G/objdir-gecko/dom/media
The following command failed to execute properly:
/usr/bin/ccache /home/lapineige/B2G/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.9/bin/arm-linux-androideabi-g++ -o MediaPermissionGonk.o -c -I/home/lapineige/B2G/objdir-gecko/dist/system_wrappers -include /home/lapineige/B2G/gecko/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DMOZILLA_INTERNAL_API -DWEBRTC_POSIX -DMOZ_OMX_DECODER -DMOZ_OMX_WEBM_DECODER -DMOZ_GONK_MEDIACODEC -DOS_POSIX=1 -DOS_LINUX=1 -DSTATIC_EXPORTABLE_JS_API -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -I/home/lapineige/B2G/gecko/dom/media -I/home/lapineige/B2G/objdir-gecko/dom/media -I/home/lapineige/B2G/gecko/caps -I/home/lapineige/B2G/gecko/dom/base -I/home/lapineige/B2G/gecko/dom/camera -I/home/lapineige/B2G/gecko/layout/generic -I/home/lapineige/B2G/gecko/layout/xul -I/home/lapineige/B2G/gecko/netwerk/base -I/home/lapineige/B2G/gecko/media/webrtc/signaling/src/common -I/home/lapineige/B2G/gecko/media/webrtc/trunk -I/home/lapineige/B2G/objdir-gecko/ipc/ipdl/_ipdlheaders -I/home/lapineige/B2G/gecko/ipc/chromium/src -I/home/lapineige/B2G/gecko/ipc/glue -I/home/lapineige/B2G/objdir-gecko/dist/include -I/home/lapineige/B2G/objdir-gecko/dist/include/nspr -I/home/lapineige/B2G/objdir-gecko/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /home/lapineige/B2G/objdir-gecko/mozilla-config.h -MD -MP -MF .deps/MediaPermissionGonk.o.pp -DANDROID -isystem /home/lapineige/B2G/bionic/libc/arch-arm/include -isystem /home/lapineige/B2G/bionic/libc/include -isystem /home/lapineige/B2G/bionic/libstdc++/include -isystem /home/lapineige/B2G/bionic/libc/kernel/uapi -isystem /home/lapineige/B2G/bionic/libc/kernel/uapi/asm-arm -isystem /home/lapineige/B2G/bionic/libm/include -isystem /home/lapineige/B2G/bionic/libm/include/arm -I/home/lapineige/B2G/system -I/home/lapineige/B2G/system/core/include -isystem /home/lapineige/B2G/bionic -I/home/lapineige/B2G/hardware/libhardware/include -I/home/lapineige/B2G/external/valgrind/fxos-include -I/home/lapineige/B2G/frameworks/native/include -I/home/lapineige/B2G/frameworks/av/include -I/home/lapineige/B2G/frameworks/av/include/media -I/home/lapineige/B2G/frameworks/av/include/camera -I/home/lapineige/B2G/frameworks/native/include/media/openmax -I/home/lapineige/B2G/frameworks/av/media/libstagefright/include -I/home/lapineige/B2G/external/mdnsresponder/mDNSShared -Wall -Wc++11-compat -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wwrite-strings -Wthread-safety -Wunreachable-code -Wno-invalid-offsetof -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -mandroid -fno-short-enums -fno-exceptions -DMOZ_ENABLE_JS_DUMP -include /home/lapineige/B2G/gonk-misc/Unicode.h -I/home/lapineige/B2G/gecko/build/stlport/stlport -I/home/lapineige/B2G/ndk/sources/cxx-stl/system/include -march=armv7-a -mthumb -mfpu=neon -mfloat-abi=softfp -mno-unaligned-access -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -std=gnu++0x -pipe -g -freorder-blocks -Os -fno-reorder-functions -funwind-tables -Werror -Wno-error=attributes /home/lapineige/B2G/gecko/dom/media/MediaPermissionGonk.cpp
/home/lapineige/B2G/gecko/config/rules.mk:918: recipe for target 'MediaPermissionGonk.o' failed
make[6]: *** [MediaPermissionGonk.o] Error 1
/home/lapineige/B2G/gecko/config/recurse.mk:71: recipe for target 'dom/media/target' failed
make[5]: *** [dom/media/target] Error 2
/home/lapineige/B2G/gecko/config/recurse.mk:32: recipe for target 'compile' failed
make[4]: *** [compile] Error 2
/home/lapineige/B2G/gecko/config/rules.mk:531: recipe for target 'default' failed
make[3]: *** [default] Error 2
/home/lapineige/B2G/gecko/client.mk:419: recipe for target 'realbuild' failed
make[2]: *** [realbuild] Error 2
client.mk:181: recipe for target 'build' failed
make[1]: *** [build] Error 2
gonk-misc/Android.mk:526: recipe for target 'out/target/product/amami/obj/DATA/gecko_intermediates/gecko' failed
make: *** [out/target/product/amami/obj/DATA/gecko_intermediates/gecko] Error 2
(Reporter)

Updated

2 years ago
Blocks: 1245091
(Reporter)

Comment 1

2 years ago
Mistake: the setup was done for amami*. I used ./config.sh amami-l

(first bug report for me, sorry for the inconvenience)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1258034
You need to log in before you can comment on or make changes to this bug.