Closed Bug 1258034 Opened 4 years ago Closed 4 years ago

MediaPermissionGonk.cpp and ServiceWorkerPrivate.cpp don't compile anymore

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox48 fixed)

RESOLVED FIXED
Tracking Status
firefox48 --- fixed

People

(Reporter: fabrice, Assigned: fabrice)

References

Details

Attachments

(2 files)

I'm on m-i rev 840c86ab171c:

/home/fabrice/dev/mozilla-inbound/dom/media/MediaPermissionGonk.cpp: In member function ‘virtual nsresult mozilla::{anonymous}::MediaPermissionRequest::Allow(JS::HandleValue)’:
/home/fabrice/dev/mozilla-inbound/dom/media/MediaPermissionGonk.cpp:247:14: error: ‘class mozilla::dom::AutoJSAPI’ has no member named ‘init’
   if (!jsapi.init(&aChoices.toObject())) {
Summary: MediaPermissionGonk.cpp doesn't compile anymore → MediaPermissionGonk.cpp and ServiceWorkerPrivate.cpp don't compile anymore
Assignee: nobody → fabrice
Attachment #8732542 - Flags: review?(khuey)
Fallout from bug 1257042
Attachment #8732543 - Flags: review?(khuey)
Blocks: 1257042
Duplicate of this bug: 1258200
You need to log in before you can comment on or make changes to this bug.