Closed Bug 1258212 Opened 4 years ago Closed 4 years ago

[e10s] navigator.registerContentHandler for RSS is broken

Categories

(Firefox Graveyard :: RSS Discovery and Preview, defect)

defect
Not set

Tracking

(e10sm9+, firefox47 fixed, firefox48 verified, firefox49 verified)

VERIFIED FIXED
Firefox 49
Tracking Status
e10s m9+ ---
firefox47 --- fixed
firefox48 --- verified
firefox49 --- verified

People

(Reporter: ojab, Assigned: mrbkap)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160320004007

Steps to reproduce:

1. Go to https://newsblur.com
2. Click Try out NewsBlur
3. Click on the gear in the bottom of left sidebar
4. Select Goodies & Mobile Apps
5. Click on the ADD TO FIREFOX button right to "Firefox: Register NewsBlur as an RSS reader" line


Actual results:

Nothing


Expected results:

Newblur RSS handler should be added
Basically it does
e = "https://www.newsblur.com/"
navigator.registerContentHandler('application/vnd.mozilla.maybe.feed', e + '?url=%s', 'NewsBlur');
navigator.registerContentHandler('application/atom+xml', e + '?url=%s', 'NewsBlur');
navigator.registerContentHandler('application/rss+xml', e + '?url=%s', 'NewsBlur')
Component: Untriaged → RSS Discovery and Preview
Blocks: 1109714
Status: UNCONFIRMED → NEW
tracking-e10s: --- → ?
Ever confirmed: true
Flags: in-testsuite?
OS: Unspecified → All
Hardware: Unspecified → All
Summary: navigator.registerContentHandler for RSS is broken → [e10s] navigator.registerContentHandler for RSS is broken
Version: 47 Branch → Trunk
Assignee: nobody → mrbkap
Attached patch PatchSplinter Review
It looks like we just forgot to hook the message up to the message manager. I tried writing a mochitest for this, but it ended up being harder than I thought it'd be, so I'm just going to check this in.
Attachment #8746236 - Flags: review?(gwright)
Comment on attachment 8746236 [details] [diff] [review]
Patch

Review of attachment 8746236 [details] [diff] [review]:
-----------------------------------------------------------------

Presumably this needs a test?
Attachment #8746236 - Flags: review?(gwright) → review+
https://hg.mozilla.org/mozilla-central/rev/5f3d4dd4380f
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 49
Do we need to uplift?  Seems like at least 47 and later could be affected...  Wherever e10s would be enabled I guess?
Flags: needinfo?(mrbkap)
Flags: needinfo?(gwright)
It could go either way. I don't think it's a risky change, but I also don't think many people use this feature. We can probably just go ahead and uplift.
Flags: needinfo?(gwright)
Comment on attachment 8746236 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: n/a (this never worked in e10s before)
[User impact if declined]: web sites that use navigator.registerContentHandler wouldn't be able to prompt the user to add them as an RSS reader.
[Describe test coverage new/current, TreeHerder]: Under covered :-(
[Risks and why]: Low risk.
[String/UUID change made/needed]: n/a
Flags: needinfo?(mrbkap)
Attachment #8746236 - Flags: approval-mozilla-beta?
Attachment #8746236 - Flags: approval-mozilla-aurora?
Comment on attachment 8746236 [details] [diff] [review]
Patch

e10s related, Aurora48+, Beta47+
Attachment #8746236 - Flags: approval-mozilla-beta?
Attachment #8746236 - Flags: approval-mozilla-beta+
Attachment #8746236 - Flags: approval-mozilla-aurora?
Attachment #8746236 - Flags: approval-mozilla-aurora+
I have reproduced this bug with Nightly 48.0a1 (2016-03-20) on Windows 10 , 32 bit.

This Bug's fix is verified on Latest beta 49.0b1 and Latest release 48 .

Build ID : 20160802125918
User Agent:Mozilla/5.0 (Windows NT 10.0; rv:49.0) Gecko/20100101 Firefox/49.0.


Build ID : 20160726073904
User Agent:Mozilla/5.0 (Windows NT 10.0; rv:48.0) Gecko/20100101 Firefox/48.0.

[bugday-20160810]
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.