getting ERROR (-238) registering MapiProxy.dll

VERIFIED DUPLICATE of bug 122725

Status

SeaMonkey
Installer
VERIFIED DUPLICATE of bug 122725
17 years ago
14 years ago

People

(Reporter: Henrik Gemal, Assigned: Michael Buckland)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I'm not really sure if it matters or not but having ERRROs in the
install_wizard.log never seems nice.

I just saw this looking through the install_wizard.log file:
     ** szDefaultMailClient: Mozilla
     ** ERROR (-238): Windows Register Server: C:\Program
Files\mozilla.org\Mozilla\MapiProxy.dll
     ** File.windowsRegisterServer(C:\Program
Files\mozilla.org\Mozilla\MapiProxy.dll\) returned: -238

I didn't get a error installing or anything i just saw the entry in the file.

Is it bad?

20020213
This probably isn't a good thing.  I don't have a MapiProxy.dll anymore, but I
do seem to have a mozMapi32.dll

MapiProxy.dll still appears in the package lists
Assignee: dveditz → ssu
Summary: getting ERROR (-238) in install_wizard.log → getting ERROR (-238) registering MapiProxy.dll
Keywords: nsbeta1
(Assignee)

Comment 2

17 years ago
Discussed in 2/27/02 Mail & News bug meeting.  Decisions was to reassign to dveditz.
Assignee: ssu → dveditz
sorry, not my bug. The script is failing because it's trying to register a file
that doesn't exist anymore. The install team are not mindreaders nor are we the
CPD janitors. Is the file simply gone? Is there some other file that's supposed
to be registered instead? These are all questions the mail team will have to answer.
Assignee: dveditz → buckland

Comment 4

17 years ago
This is happening because makefile.win was changed for static builds, the change
made this dll stop from being built which is not correct. We need to build and
generate this MapiProxy dll as well register it for MAPI support to work. This
problem will be fixed as part of the bug # 122725 which should start generating
this dll.

Marking this as a duplicate of bug # 122725. Although the bug description for
122725 says something else it is essentially the same problem and the same fix
is needed for both.

*** This bug has been marked as a duplicate of 122725 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
verified
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → gbush
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.