Search/URL bar's prefill-as-you-type functionality interferes with user's input

RESOLVED DUPLICATE of bug 1222889

Status

()

Firefox for Android
Awesomescreen
RESOLVED DUPLICATE of bug 1222889
2 years ago
2 years ago

People

(Reporter: Grisha, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Steps to reproduce:
- aggregate some browsing history on, for example, HN: http://news.ycombinator.com/ - open a few comment pages, etc
- in the URL bar, start typing in HN's url - "news." - you should see that the rest of the base url "prefills" and is currently "selected"
- don't finish typing, but rather click past the end of the url
- selection disappears, cursor is at the end
- start typing the rest of the url. in case of HN, it might be something like "item?id=123" 
- you'll see that as you type the 1st character, another part of the url prefills automatically ("item" in this case), but it isn't selected and doesn't give way to your input - so if you continue to type, you'll end up with something like "news.ycombinator.com/itemtem"

Note that this doesn't happen if you start with a full URL, put cursor at the end, erase a portion of it, and start typing - everything behaves normally.

Comment 1

2 years ago
This sounds like a dupe of bug 1222889.
Flags: needinfo?(nchen)
Yes I agree.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(nchen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1222889
You need to log in before you can comment on or make changes to this bug.