"File not found" errors in xpcshell/mozmill following bug 1242632

RESOLVED FIXED in Firefox 48

Status

()

Core
Build Config
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: aleth, Assigned: aleth)

Tracking

({regression})

48 Branch
mozilla48
regression
Points:
---

Firefox Tracking Flags

(firefox48 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Spun out of bug 1254987.

Note these failures can be reproduced locally.
(Assignee)

Updated

2 years ago
Blocks: 1254987
Keywords: regression
(Assignee)

Comment 1

2 years ago
Looks like it's not a relative path issue: objdir/_tests/xpcshell/mailnews/resources doesn't exist after the build.
(Assignee)

Comment 2

2 years ago
Looks like Bug 1140161 has broken.
(Assignee)

Comment 3

2 years ago
Probably by Bug 1242632.
(Assignee)

Updated

2 years ago
Depends on: 1259219
(Assignee)

Comment 4

2 years ago
Indeed, backing out bug 1242632 "fixes" this bug.

The relevant moz.builds with TEST_HARNESS_FILES absolute paths are 
mail/test/mozmill/moz.build
mailnews/moz.build

mshal, any ideas as to what might be going wrong?
(Assignee)

Updated

2 years ago
Blocks: 1242632
No longer depends on: 1259219
(Assignee)

Updated

2 years ago
Flags: needinfo?(mshal)
(Assignee)

Comment 5

2 years ago
I suspect https://hg.mozilla.org/mozilla-central/rev/bb230d696c72#l1.97 isn't the right thing to do when an absolute path is provided in TEST_HARNESS_FILES.
(Assignee)

Comment 6

2 years ago
(By "absolute path" I mean https://hg.mozilla.org/mozilla-central/file/bb230d696c72/python/mozbuild/mozbuild/frontend/context.py#l1750)
(Assignee)

Comment 7

2 years ago
Created attachment 8734112 [details] [diff] [review]
Fix absolute paths in TEST_HARNESS_FILES

This seems to fix the regression, but is possibly a bit of a hack.
Attachment #8734112 - Flags: feedback?(mshal)
(Assignee)

Updated

2 years ago
Assignee: nobody → aleth
Status: NEW → ASSIGNED
(Assignee)

Updated

2 years ago
No longer blocks: 1254987
Component: Build Config → Build Config
Product: Thunderbird → Core
Summary: "File not found" errors in xpcshell/mozmill following recent configure changes → "File not found" errors in xpcshell/mozmill following bug 1242632
Comment on attachment 8734112 [details] [diff] [review]
Fix absolute paths in TEST_HARNESS_FILES

I think that seems reasonable. Though why do you need to add support for it at all? Couldn't you use local paths instead?


TEST_HARNESS_FILES.xpcshell.mailnews.data += [
    '/mailnews/test/data/**',
]

TEST_HARNESS_FILES.xpcshell.mailnews.resources += [
    '/mailnews/test/resources/**',
]

to:


TEST_HARNESS_FILES.xpcshell.mailnews.data += [
    'test/data/**',
]

TEST_HARNESS_FILES.xpcshell.mailnews.resources += [
    'test/resources/**',
]
Flags: needinfo?(mshal)
Attachment #8734112 - Flags: feedback?(mshal) → feedback+
(Assignee)

Comment 9

2 years ago
(In reply to Michael Shal [:mshal] from comment #8)
> TEST_HARNESS_FILES.xpcshell.mailnews.resources += [
>     'test/resources/**',
> ]

The problem is that this would end up with files copied to .../xpcshell/mailnews/resources/test/resources.
(Assignee)

Comment 10

2 years ago
Comment on attachment 8734112 [details] [diff] [review]
Fix absolute paths in TEST_HARNESS_FILES

Note this simple patch would fail if there are absolute paths with wildcards in the middle somewhere (/whatever/*/something); not sure if that is supported.
Attachment #8734112 - Flags: review?(mshal)
(Assignee)

Comment 11

2 years ago
(In reply to aleth [:aleth] from comment #9)
> The problem is that this would end up with files copied to
> .../xpcshell/mailnews/resources/test/resources.

One might be able to work around that one, but this example here seems impossible:

https://dxr.mozilla.org/comm-central/source/mail/test/mozmill/moz.build#12

Updated

2 years ago
Attachment #8734112 - Flags: review?(mshal)
Attachment #8734112 - Flags: review+
Attachment #8734112 - Flags: feedback+
(Assignee)

Comment 12

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/8b62c5b05ff1fee583c76e8c697e51e8f823aadc
Bug 1259174 - Fix absolute paths in TEST_HARNESS_FILES. r=mshal
https://hg.mozilla.org/mozilla-central/rev/8b62c5b05ff1
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox48: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
You need to log in before you can comment on or make changes to this bug.