trying to close browser tab with pdf file (acrobat reader plugin) closes background tab instead of focused one

RESOLVED WORKSFORME

Status

SeaMonkey
Tabbed Browser
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Kris Kelvin, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.8+) Gecko/20020215
BuildID:    2002021503

I viewed the above pdf in a browser tab with acrobat reader plugin based on
Acrobat reader 5.01 27.03.01. Another tab was oben in background. When focues
the pdf-tab, pressed the close (X) button in the tab-bar: this closed the
background window instead of the focused one.

Reproducible: Always
Steps to Reproduce:
1. open above pdf-document (or maybe any)
2. open new tab with some file or url
3. focus the pdf-tab
4. press the close button on the right of tab-header bar

Actual Results:  background tab is closed
Expected Results:  focused tab is closed
(Reporter)

Comment 1

17 years ago
Bug is only reproduceable when the above pdf file had opened new browser window
before by clicking on a target-blanc link. 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
This may or may not be related to this problem, but it seems to be related. 
When viewing a PDF file (in the Adobe Acrobat Reader v5.0.5 plugin in a Tab, the
Back and Forward buttons do not work.  If you jump between tabs while one Tab is
displaying a PDF file, the Forward and Back buttons do not work in the Tab with
the PDF file.  Also, the Location box does not get updated.  It continues to
show the URL for the last tab you were in before switching to the PDF tab.  The
Forward and Back buttons, as well as the Location box do work correctly in Tabs
that are not displaying PDF files.  As soon as you leave the PDF file that Tab
will start working correctly again.
(Assignee)

Comment 3

16 years ago
That's bug 139321.

Comment 4

16 years ago
Releated: bug 139087

Comment 5

16 years ago
Related to this problem:
- I've open several tabs, at least one (in background) with an open PDF
- I want to search some text in the non-PDF tab using Ctrl+F
This launches the acrobat search function and a) interrupts the download of the
PDF in background b) blocks this browser window until a timeout of the PDF in
background appears.

--> It's really odd that the Acrobat search function is called when I hit Ctrl+F
in a Tab which is NOT a PDF file.

Mozilla 1.1 Win2k Acrobat Reader 5.0
QA Contact: sairuh → pmac

Comment 6

14 years ago
Is this bug actually still alive?  I've never seen this behavior in all the
times I've used tabs while viewing PDFs.  There have been so many improvements
to tabbed browsing, and much newer versions of the Acrobat Reader plugin.  And
no activity in the bug for about 1 1/2 years...

Comment 7

14 years ago
The problem with the odd search behavior is fixed. Acrobat 6.0 and Mozilla 1.6
(WinXP) work fine. I guess the Acrobat 5 plugin was quite buggy.
I couldn't reproduce any of the described scenarios here with my config. Close it?

Comment 8

14 years ago
(In reply to comment #7)
> I couldn't reproduce any of the described scenarios here with my config. Close it?

No - I regularly hit this with Acroread 6.0 and Firefox 0.10.1 and Netscape 8
beta. Sometimes closing the tab or just pushing the Back button brings the whole
browser down. It doesn't crash: it only takes ages (several unbearable minutes
on a 2G p4) to recover with full cpu load. Furthermore it isn't easy to
reproduce; it just happens sometimes - sometimes not. It's a showstopper for my
elders... If I kill acroread off the process list, firefox can recover easily.

Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
File name: nppdf32.dll    Adobe Acrobat Plug-In Version 6.00 for Netscape

Comment 9

14 years ago
Recently, closing a pdf document has occasionally been crashing the whole
browser for me.  I'm currently running the firefox 1.0rc, but earlier PR/betas
exhibited the same behavior.  Note that I also experience bug 198954

Comment 10

13 years ago
I'm seeing this with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050415 Firefox/1.0+.  Stange thing is that the "wrong" tab is not
actually closed - it just becomes invisible.  I can switch to it using Ctrl-Tab,
or restore the tabs by opening a new one.  Very weird.

Comment 11

10 years ago
WFM with current trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008020404 Minefield/3.0b3pre
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.