Product image not changing upon selection in Woocommerce/Wordpress

VERIFIED FIXED in Firefox 45

Status

()

VERIFIED FIXED
3 years ago
10 days ago

People

(Reporter: stratsimir.trifonov3, Assigned: jdm)

Tracking

({dev-doc-complete, regression, site-compat})

Trunk
mozilla48
dev-doc-complete, regression, site-compat
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox45blocking verified, firefox46+ verified, firefox47+ fixed, firefox48+ verified, firefox-esr4546+ verified, relnote-firefox 45+)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160315153207

Steps to reproduce:

After an update of Mozilla browser from ver. 44.0.2 to 45.0.1, the selection of product color in an online clothes store doesn't change to the respective image. 
Please refer to, for example this product - http://fashionchoice.bg/?product=efekten-maksi-zhaket-za-proletta-s-dzhobcheta-v-chetiri-tsvyata
or any other product on the online store fashionchoice.bg It is Wordpress based, using woocommerce plugin.




Actual results:

Upon selection of an available color from the first dropdown menu to the right of the image, the image used to change to the respective one, up to Mozilla 44.0.2 and rest of the browsers, but not in ver. 45


Expected results:

Upon selection of the color from the dropdown menu, the respective image for the variation should be displayed as it used to in the version of Mozilla 44.0.2 and before, as well as the rest of the browsers like Google and IE.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
I can reproduce the issue. Investigating.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, regressionwindow-wanted, site-compat
OS: Windows 10 → All
Hardware: x86_64 → All
Regression range: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3cc3b1968524248450c465c4ea2ee5596ffa65f2&tochange=285852de5cd54891d8f3b1ddbff179e4c9c7ca5f

Culprit: Bug 1166138

[Tracking Requested - why for this release]: site compatibility regression, affecting WooCommerce sites.
Blocks: 1166138
status-firefox45: --- → affected
status-firefox46: --- → affected
status-firefox47: --- → affected
status-firefox48: --- → affected
status-firefox-esr45: --- → affected
tracking-firefox45: --- → ?
tracking-firefox46: --- → ?
tracking-firefox47: --- → ?
tracking-firefox48: --- → ?
tracking-firefox-esr45: --- → ?
relnote-firefox: --- → ?
Component: Untriaged → DOM
Flags: needinfo?(michael)
Keywords: regressionwindow-wanted → dev-doc-needed, testcase
Product: Firefox → Core
Version: 45 Branch → Trunk
Hi Andrew, this is a major site-compat issue that was flagged on Fx45. Could you please help find an owner who can investigate? If this is something on our side, we may consider doing a dot release for this and two other site compat issues that were flagged by Kohei. Thanks!
Flags: needinfo?(overholt)
Looks like this bug is affecting the YITH WooCommerce Zoom Magnifier plugin that has 90,000+ active installs:

https://wordpress.org/plugins/yith-woocommerce-zoom-magnifier/

There are a couple of relevant bug reports in their plugin forum:

https://wordpress.org/support/plugin/yith-woocommerce-zoom-magnifier
Josh and Edgar have recently been looking at responsive images code.
Flags: needinfo?(overholt)
Flags: needinfo?(josh)
Flags: needinfo?(echen)
(Assignee)

Updated

3 years ago
Assignee: nobody → josh
Flags: needinfo?(michael)
Flags: needinfo?(josh)
Flags: needinfo?(echen)
(Assignee)

Comment 7

3 years ago
For the record, investigating the behaviour of the original URL testcase makes it look like the image srcset is changing but not the src attribute. Presumably that's taking precedence for some reason?
(Assignee)

Comment 8

3 years ago
Interestingly, in Chrome the src attribute is changed as well.
(Assignee)

Comment 9

3 years ago
Nope, that was a red herring from me misreading the HTML. Both attributes contain the expected value.
(Assignee)

Comment 10

3 years ago
John, do you feel like reviewing this or should I find somebody else?
Attachment #8735560 - Flags: review?(john)
Tracking, affects many sites, popular yahoo theme
tracking-firefox46: ? → +
tracking-firefox47: ? → +
tracking-firefox48: ? → +
Comment on attachment 8735560 [details] [diff] [review]
Ensure that image loads are never dropped on the floor when queued for later

Review of attachment 8735560 [details] [diff] [review]:
-----------------------------------------------------------------

Good catch, LGTM
Attachment #8735560 - Flags: review?(john) → review+
(Assignee)

Comment 14

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/5df20795af1438c88a7997255e52ac44ec07047e
Bug 1259482 - Ensure that image loads are never dropped on the floor when queued for later. r=johns

Comment 15

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5df20795af14
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox48: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
(In reply to Ritu Kothari (:ritu) from comment #4)
> Hi Andrew, this is a major site-compat issue that was flagged on Fx45. Could
> you please help find an owner who can investigate? If this is something on
> our side, we may consider doing a dot release for this and two other site
> compat issues that were flagged by Kohei. Thanks!

Do we need to uplift the fix here, Ritu?
Flags: needinfo?(rkothari)
This bug is a driver of the potential 45.0.2 release. The patch needs to be uplifted.

https://wiki.mozilla.org/Firefox/Channels/Meetings/2016-04-05
Josh, could you fill the uplift request for aurora, beta, release & esr45? Thanks
Flags: needinfo?(josh)
tracking-firefox45: ? → blocking
tracking-firefox-esr45: ? → 46+
(In reply to Andrew Overholt [:overholt] from comment #16)
> (In reply to Ritu Kothari (:ritu) from comment #4)
> > Hi Andrew, this is a major site-compat issue that was flagged on Fx45. Could
> > you please help find an owner who can investigate? If this is something on
> > our side, we may consider doing a dot release for this and two other site
> > compat issues that were flagged by Kohei. Thanks!
> 
> Do we need to uplift the fix here, Ritu?

Yes, we definitely should. Sylvestre has requested Josh to nominate the patch for uplift.
Flags: needinfo?(rkothari)
Hello Miro, could you please verify this issue is fixed in the latest version of Nightly? Thanks!
Flags: qe-verify+
Flags: needinfo?(stratsimir.trifonov3)
(Assignee)

Comment 21

3 years ago
Comment on attachment 8735560 [details] [diff] [review]
Ensure that image loads are never dropped on the floor when queued for later

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration: significant breadth of impact
User impact if declined: degraded user experience on sites using very popular wordpress plugin
Fix Landed on Version: 48
Risk to taking this patch (and alternatives if risky): At worst, unnecessary extra image loads.
String or UUID changes made by this patch: None

See https://wiki.mozilla.org/Release_Management/ESR_Landing_Process for more info.

Approval Request Comment
[Feature/regressing bug #]: 1166138
[User impact if declined]: degraded experience on sites using popular wordpress plugin
[Describe test coverage new/current, TreeHerder]: Regression test added in patch.
[Risks and why]: At most, unnecessary extra image loads if logic is incorrect.
[String/UUID change made/needed]: None
Flags: needinfo?(josh)
Attachment #8735560 - Flags: approval-mozilla-esr45?
Attachment #8735560 - Flags: approval-mozilla-beta?
Attachment #8735560 - Flags: approval-mozilla-aurora?
Comment on attachment 8735560 [details] [diff] [review]
Ensure that image loads are never dropped on the floor when queued for later

[Triage Comment]
Attachment #8735560 - Flags: approval-mozilla-release+
Attachment #8735560 - Flags: approval-mozilla-esr45?
Attachment #8735560 - Flags: approval-mozilla-esr45+
Attachment #8735560 - Flags: approval-mozilla-beta?
Attachment #8735560 - Flags: approval-mozilla-beta+
Attachment #8735560 - Flags: approval-mozilla-aurora?
Attachment #8735560 - Flags: approval-mozilla-aurora+
(Reporter)

Comment 24

3 years ago
(In reply to Ritu Kothari (:ritu) from comment #20)
> Hello Miro, could you please verify this issue is fixed in the latest
> version of Nightly? Thanks!

Hi Ritu Kothari, tried the beta ver. 46.08b, problem still persists.
Flags: needinfo?(stratsimir.trifonov3)
(In reply to Miro Trifonov from comment #24)
> (In reply to Ritu Kothari (:ritu) from comment #20)
> > Hello Miro, could you please verify this issue is fixed in the latest
> > version of Nightly? Thanks!
> 
> Hi Ritu Kothari, tried the beta ver. 46.08b, problem still persists.

The only builds that would have the fix for this would be Nightly builds, available from https://nightly.mozilla.org/
Flags: needinfo?(stratsimir.trifonov3)
(Reporter)

Comment 26

3 years ago
(In reply to Wes Kocher (:KWierso) from comment #25)
> (In reply to Miro Trifonov from comment #24)
> > (In reply to Ritu Kothari (:ritu) from comment #20)
> > > Hello Miro, could you please verify this issue is fixed in the latest
> > > version of Nightly? Thanks!
> > 
> > Hi Ritu Kothari, tried the beta ver. 46.08b, problem still persists.
> 
> The only builds that would have the fix for this would be Nightly builds,
> available from https://nightly.mozilla.org/

Sorry for the misunderstanding. Yes, I confirm that now it works just fine with the nightly.
Flags: needinfo?(stratsimir.trifonov3)

Comment 27

3 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-esr45/rev/91196854ad1a
Landed to GECKO4501esr_2016031618_RELBRANCH
I can confirm that the issue is fixed when I follow the STR from the description on FF 45.0.2-build1, FF 45.0.2esr-build1 and FF 46.0b9. Verified on Ubuntu 14.04, Windows 8.1, Windows 10 and Mac OS X 10.10. 

But the issue is still intermittently reproducible with this scenario:

1. Go to http://fashionchoice.bg/?product=efekten-maksi-zhaket-za-proletta-s-dzhobcheta-v-chetiri-tsvyata
2. When the page is loading try to change (ЦВЯТ)color dropdown menu
3. Press F5 many times and try to change color dropdown menu (the carousel will get stuck at some point - average 10-12 page refreshes should do the trick)


Actual results: When the steps are successful the carousel gets stuck and the drop down selector doesn't trigger any change anymore. 

Expected Results: When I change the color dropdown menu, the carousel should change with the according color selected. 


I've still managed to reproduce this issue on 45.0.2-build1, 45.0.2esr-build1 and 46.0b9, although intermittently:
* 45.0.2-build1 (rarely)
* 45.0.2esr -build1(intermittent)
* 46.0b9-build1(intermittent)

Josh would you prefer me to file a new bug for this?
Flags: needinfo?(josh)
Johns, Josh, what do you think? Should we postpone 45.0.2?
Flags: needinfo?(john)
Andrew, do you know who could help on this?
This is blocking 45.0.2 as the intermittent issue might hide other issues.
Flags: needinfo?(overholt)
(Assignee)

Comment 31

3 years ago
I haven't been able to reproduce this problem yet. I think we should file it separately and it shouldn't postpone 45.0.2.
(Assignee)

Updated

3 years ago
Flags: needinfo?(josh)
Flags: needinfo?(john)
Flags: needinfo?(overholt)
Josh, you confirm you are not expecting side effects on this, right?
Flags: needinfo?(josh)
I have run again the test on 45.0.2esr,46.0b9 for this issue and as I mentioned above is not easy to reproduce it, I have tried 8 times with new profile each time and I manage to reproduce 2 times. I will file a new bug separately of this.
(Assignee)

Comment 34

3 years ago
That is what I wrote in the uplift request, yes.
Flags: needinfo?(josh)
 Verified fixed on Windows 10 x64, Mac OS X 10.10 and Ubuntu 14.04 on Firefox 45.0.2-build3, 
 45.0.2esr -build1, 46.0b9-build1. I can't reproduce this issue, this bug can be marked as verified fixed.

For the scenario from comment 28 I have filed a new bug 1263834.

I have tested with Nightly 48.0a1 I can't reproduce the reported issue but I found another bug that is related with the site example from description, the scenario is different, it is a e10s bug. Please see bug 1263887.
Status: RESOLVED → VERIFIED
status-firefox45: fixed → verified
status-firefox46: fixed → verified
status-firefox48: fixed → verified
status-firefox-esr45: fixed → verified
This was noted for 45.0.2 (https://www.mozilla.org/en-US/firefox/45.0.2/releasenotes/) as "Fix a web compatibility regression impacting the srcset attribute of the image tag (1259482)"
relnote-firefox: ? → 45+
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.