Corrupted video rendering - only 1/4 part of frame is being updated

VERIFIED FIXED in Firefox 48

Status

()

Core
Panning and Zooming
--
major
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: RyanVM, Assigned: kats)

Tracking

({regression})

48 Branch
mozilla48
regression
Points:
---

Firefox Tracking Flags

(firefox47 unaffected, firefox48 verified)

Details

(URL)

(Reporter)

Description

2 years ago
[Tracking Requested - why for this release]: Image rendering regression.

Looks like the other 3/4 isn't being invalidated? Regression range seems to fit that.

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=52a994f0744c9b2ad154906af5bb4508ed021438&tochange=b9520981c35aae7ba1995cb5145899b880fc56f1

Regression from bug 1254134. Matt, can you please look at this since kats is out for a week?
Flags: needinfo?(matt.woodrow)
(Reporter)

Comment 1

2 years ago
Hopefully we can add a test for this too.
Flags: in-testsuite?
Keywords: regression
(Reporter)

Comment 2

2 years ago
Also, I have a hidpi screen w/ 200% scaling in case that matters.
Feel free to back out bug 1254134 and I can look at it when I get back. Although with all this freezing rain I might not actually be going anywhere...
(Reporter)

Comment 4

2 years ago
Fixed by backing out bug 1254134.
Assignee: nobody → bugmail.mozilla
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox48: affected → fixed
tracking-firefox48: ? → ---
Flags: needinfo?(matt.woodrow)
Flags: in-testsuite?
Resolution: --- → FIXED
Target Milestone: --- → mozilla48

Updated

2 years ago
Duplicate of this bug: 1259714
(Reporter)

Comment 6

2 years ago
backoutbugherder
Backout merged to m-c and new nightlies requested.
https://hg.mozilla.org/mozilla-central/rev/a3994143ea12
Severity: normal → major
Status: RESOLVED → VERIFIED
status-firefox47: --- → unaffected
status-firefox48: fixed → verified
Summary: Only 1/4 of gifv is animated → Corrupted video rendering - only 1/4 part of frame is being updated
Version: Trunk → 48 Branch
Duplicate of this bug: 1260662
You need to log in before you can comment on or make changes to this bug.