Closed Bug 1259767 Opened 6 years ago Closed 6 years ago

Themes option not available in Customize Mode while using a complete theme

Categories

(Firefox :: Toolbars and Customization, defect)

46 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox45 --- affected
firefox46 --- affected
firefox47 --- affected
firefox48 --- affected

People

(Reporter: JuliaC, Unassigned)

Details

Attachments

(1 file)

[Affected versions]:
- 46.0b5-build2 (20160324011246)

[Affected platforms]:
- Windows 10 x64
- Windows 8 x64
- Mac OS X 10.10.5
- Ubuntu 14.04 x86

[Steps to reproduce]:
1. Launch Firefox with a new profile.
2. Install a complete theme (e.g. from https://addons.mozilla.org/en-US/firefox/complete-themes/). 
3. Restart the browser to complete the theme installation. 
4. Enter Customize Mode via menu (≡) → Customize.
5. Inspect the available options.

[Expected result]:
- The user should be able to access all the Customize options, including Themes option, like in the Default theme or in a lightweight one.

[Actual result]:
- Themes option is missing from Customize Mode.

[Additional notes]:
- Reproducible also with 44.0RC build 2 
- The issue is not a recent regression
Pretty sure this is intentional -- bug 1073240 added code to explicitly hide this button when not using the default theme. Lightweight themes can't work without the complete theme supporting it, so we don't want to show a button that might not work.

I'm not sure what the state of support is for this, though. IIRC at one point some theme authors were interested in having this work, but I'm not sure if that happened of if Firefox can tell if a complete theme supports LWTs... Gijs? (Doesn't really matter, since complete theme support is being deprecated.)
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Justin Dolske [:Dolske] from comment #1)
> Pretty sure this is intentional -- bug 1073240 added code to explicitly hide
> this button when not using the default theme. Lightweight themes can't work
> without the complete theme supporting it, so we don't want to show a button
> that might not work.
> 
> I'm not sure what the state of support is for this, though. IIRC at one
> point some theme authors were interested in having this work, but I'm not
> sure if that happened of if Firefox can tell if a complete theme supports
> LWTs... Gijs? (Doesn't really matter, since complete theme support is being
> deprecated.)

I don't *think* so, but Mossop can confirm for sure.
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(dtownsend)
Bug 520124 was the plan, but now the plan is to drop complete themes at some point. Either way, yes it is intentional that you can't do this right now.
Flags: needinfo?(dtownsend)
Seconding Mossop, this was by design.

Closing this as "wontfix" since we are planning on dropping complete theme support.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.