URLs copied in reader mode / view prepend about:reader?url=

RESOLVED DUPLICATE of bug 1257804

Status

()

RESOLVED DUPLICATE of bug 1257804
3 years ago
3 years ago

People

(Reporter: caspy77, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
1) View any page (which qualifies) in Reader View.
2) Click the URL and copy it
3) paste it somewhere

Expected:
The pasted URL appears identical to the apparently copied URL.

Actual:
The pasted URL has about:reader?url= appended to the front along with converted characters throughout.

Additionally (and I don't know if the fix for this would fix it) the *built in* firefox function to email a page passes on the likewise mangled URL which could lead to users unknowingly (absentmindedly) sending broken links.

Just tested and I'm not seeing this on 45 or beta 46, but am on 47, so definitely a regression.
Hope we can get this fixed before shipping.
(Reporter)

Updated

3 years ago
Version: unspecified → 47 Branch

Updated

3 years ago
Summary: URLs copied in reader mode / view append about:reader?url= → URLs copied in reader mode / view prepend about:reader?url=
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1257804
You need to log in before you can comment on or make changes to this bug.