If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

PDF render fails with matlab-rendered image

VERIFIED FIXED in Firefox 48
(NeedInfo from)

Status

()

Firefox
PDF Viewer
P3
normal
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: kwalsh, Assigned: yury, NeedInfo)

Tracking

(Depends on: 1 bug, {regression})

41 Branch
Firefox 48
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 wontfix, firefox46 wontfix, firefox47 affected, firefox48 verified, firefox-esr45 affected)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/7184)

Attachments

(1 attachment)

776.48 KB, application/pdf
Details
(Reporter)

Description

2 years ago
Created attachment 8736063 [details]
err.pdf

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.87 Safari/537.36

Steps to reproduce:

View the attached PDF with builtin PDF viewer


Actual results:

Image within PDF renders slowly as a sequence of many thousands of seemingly randomly-colored rectangles and random lines.


Expected results:

Image should have rendered as a nice, red/blue-shaded curved 3D graphic, as it appears in Adobe Reader, Chrome's PDF viewer, Inkscape, and other similar PDF viewers.

Updated

2 years ago
Component: Untriaged → PDF Viewer
Product: Core → Firefox

Updated

2 years ago
status-firefox45: --- → affected
status-firefox46: --- → affected
status-firefox47: --- → affected
status-firefox48: --- → affected
status-firefox-esr45: --- → affected

Comment 1

2 years ago
Regression window:
Good but no shading color:
https://hg.mozilla.org/integration/fx-team/rev/13cfa6b095a0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0 ID:20150806095258

Bad(completely broken)
https://hg.mozilla.org/integration/fx-team/rev/7216b345380e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0 ID:20150806121442

Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=13cfa6b095a0&tochange=7216b345380e

Regressed by: 	1a75b4e0ac8b	Ryan VanderMeulen — Bug 1188344 - Update pdf.js to version 1.1.366. r=bdahl
Blocks: 1188344
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Version: 43 Branch → 41 Branch

Comment 2

2 years ago
Yuri, do you want to track this?
Flags: needinfo?(ydelendik)
(Assignee)

Comment 3

2 years ago
It's interesting that it is working in PDF.js in Safari.

Temporary workaround at https://github.com/mozilla/pdf.js/pull/7184, filing upstream issues.

(In reply to Alice0775 White from comment #1)
> Good but no shading color:

> Regressed by: 	1a75b4e0ac8b	Ryan VanderMeulen — Bug 1188344 - Update pdf.js
> to version 1.1.366. r=bdahl

Bug 1188344 adds support for mesh types, so it's not really are regression since in before and after cases rendering was incorrect.
Flags: needinfo?(ydelendik)
Whiteboard: [pdfjs-c-rendering]
(Assignee)

Updated

2 years ago
Depends on: 1263776
(Assignee)

Comment 4

2 years ago
Filed https://bugs.chromium.org/p/chromium/issues/detail?id=602509 and https://bugzilla.mozilla.org/show_bug.cgi?id=1263776
OS: Unspecified → All
Priority: -- → P3
Hardware: Unspecified → All
Whiteboard: [pdfjs-c-rendering] → [pdfjs-c-rendering][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/7184

Updated

a year ago
status-firefox45: affected → wontfix
status-firefox46: affected → wontfix
needs an owner
Flags: needinfo?(bugs)
Ryan: Bug 1263067 just missed PR #7184 that fixes this bug for us (see comment 3.) Please mark this bug fixed when you land the next "Update pdf.js to version 1.x" bug. Thanks!
Flags: needinfo?(bugs) → needinfo?(ryanvm)
Blocks: 1265738
Should be fixed on trunk now.
Assignee: nobody → ydelendik
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox48: affected → fixed
Flags: needinfo?(ryanvm)
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
(Assignee)

Comment 8

a year ago
Jet, I think you meant to be NI'ed on bug 1263776 at comment 5.
We've let this ride in a couple of releases. 47 is marked as affected and hasn't shipped. Should we take this fix in 47?
Flags: needinfo?(ydelendik)
QA Whiteboard: [good first verify]

Comment 10

a year ago
I have successfully reproduce this bug on firefox nightly 48.0a1 (2016-03-29)
(Build ID: 20160329030246)
with windows 7 (32 bit)

I found this fix on latest beta 48.0b2

Mozilla/5.0 (Windows NT 6.1; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID : 20160620091522

[bugday-20160622]
I have reproduced the bug on Firefox Nightly 48.0a1 (2016-03-29) with Linux Mint 64 bit.

The Bug's fix is verified on Latest beta 48.0b7

Build ID      20160711002726
User Agent    Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0

[bugday-20160713]
As this bug is verified on Windows (Comment 10) and Linux (Comment 11), marking this as verified !
Status: RESOLVED → VERIFIED
QA Whiteboard: [good first verify] → [bugday-20160713]
status-firefox48: fixed → verified
You need to log in before you can comment on or make changes to this bug.