Lots of BadDrawable crashes recently

RESOLVED DUPLICATE of bug 57188

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 57188
16 years ago
13 years ago

People

(Reporter: Cesar Eduardo Barros, Assigned: asa)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020215
BuildID:    2002021513

When I tried to load the ageofconsent site (typing www.ageofconsent.com on a new
browser window), I got a stream of image warnings (more than 5 for
www.ageofconsent.com, with about 2 for other sites in between). After clicking
OK on them (with the "don't ask me again" checkbox enabled, as always), the
browser crashed with two BadDrawable and no QFA window.

Reproducible: Didn't try
Steps to Reproduce:
1.With image warnings enabled, load www.ageofconsent.com

Actual Results:  
Gdk-ERROR **: BadDrawable (invalid Pixmap or Window parameter)
  serial 1224395 error_code 9 request_code 70 minor_code 0
Gdk-ERROR **: BadDrawable (invalid Pixmap or Window parameter)
  serial 1224398 error_code 9 request_code 69 minor_code 0

on the console; all other two open windows closed

Expected Results:  Not crashed; showed the image warning for
www.ageofconsent.com only once.

The bug is probably unreproducible; like other crashes at the image warning
dialog, it's probably highly dependent on timing.

Comment 1

16 years ago
No warnings on a current CVS build, Linux, RH7.1+errata.

Comment 2

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020216
I crashed, talkback ID TB3033423Z
no crash if warnings are off

Comment 3

16 years ago
debug build throws tons of assertions while it is popping up the dialog boxes to
the tune of:

###!!! ASSERTION: recursive painting not permitted: '!(PR_TRUE == mPainting)',
file nsViewManager.cpp, line 623
###!!! Break: at file nsViewManager.cpp, line 623
###!!! ASSERTION: View manager cannot handle events during a paint:
'!mPainting', file nsViewManager.cpp, line 1941
###!!! Break: at file nsViewManager.cpp, line 1941

stacktrace to follow

Comment 4

16 years ago
Created attachment 70016 [details]
stacktrace with symbols

note #2: aWidth=14384, aHeight=13040
looks a bit suspicious.
(Reporter)

Comment 5

16 years ago
Got again, same build, this time at geocrawler, no QFA again, closed two windows
at once again, after two image dialogs (for the same site):


Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 158 (gdk_draw_polygon): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 158 (gdk_draw_polygon): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 158 (gdk_draw_polygon): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 158 (gdk_draw_polygon): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkgc.c: line 51 (gdk_gc_new_with_values): assertion
`window != NULL' failed.

Gdk-CRITICAL **: file gdkgc.c: line 662 (gdk_gc_set_clip_mask): assertion `gc !=
NULL' failed.

Gdk-CRITICAL **: file gdkgc.c: line 648 (gdk_gc_set_clip_origin): assertion `gc
!= NULL' failed.

Gdk-CRITICAL **: file gdkwindow.c: line 988 (gdk_window_copy_area): assertion
`window != NULL' failed.

Gdk-CRITICAL **: file gdkgc.c: line 288 (gdk_gc_unref): assertion `gc != NULL'
failed.

Gdk-CRITICAL **: file gdkdraw.c: line 158 (gdk_draw_polygon): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 158 (gdk_draw_polygon): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 158 (gdk_draw_polygon): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 158 (gdk_draw_polygon): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

Gdk-CRITICAL **: file gdkdraw.c: line 65 (gdk_draw_line): assertion `drawable !=
NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 65 (gdk_draw_line): assertion `drawable !=
NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 65 (gdk_draw_line): assertion `drawable !=
NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 65 (gdk_draw_line): assertion `drawable !=
NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 65 (gdk_draw_line): assertion `drawable !=
NULL' failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 158 (gdk_draw_polygon): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 158 (gdk_draw_polygon): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 158 (gdk_draw_polygon): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 158 (gdk_draw_polygon): assertion
`drawable != NULL' failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.
Gdk-ERROR **: BadValue (integer parameter out of range for operation)
  serial 390146 error_code 2 request_code 53 minor_code 0
Gdk-ERROR **: BadDrawable (invalid Pixmap or Window parameter)
  serial 390148 error_code 9 request_code 70 minor_code 0

Also, this bug is related to bug 57188 (where's the "related bugs" field?...)
Keywords: crash

Comment 6

16 years ago
looks more like a dupe of bug #57188
(Reporter)

Comment 7

16 years ago
And again at www.webstandards.org (after finding out IE doesn't even support
Level 1...), but this time *no* image warning:

Gdk-ERROR **: BadDrawable (invalid Pixmap or Window parameter)
  serial 1205454 error_code 9 request_code 70 minor_code 0
Gdk-ERROR **: BadDrawable (invalid Pixmap or Window parameter)
  serial 1205461 error_code 9 request_code 70 minor_code 0

Should I retitle?
(Reporter)

Comment 8

16 years ago
Another one, TB3073094Z:


Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.

** CRITICAL **: file nsRenderingContextGTK.cpp: line 2002 (static void
nsRenderingContextGTK::my_gdk_draw_text(struct GdkDrawable *, struct GdkFont *,
struct GdkGC *, gint, gint, const gchar *, gint)): assertion `drawable != NULL'
failed.
Summary: BadDrawable after lots of image warnings → Lots of BadDrawable crashes recently

Comment 9

16 years ago
the crash occurs here when Mozilla pops up 2 dialogs at the same time (same
problem as in bug #57188).

Comment 10

16 years ago
Just for the record I reproduced this easily with 2002041707 Linux.

This crash is reproduced in an identical way to that of bug 57188. Marking as
dup per Andrew's comments.

*** This bug has been marked as a duplicate of 57188 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.