Closed Bug 1261048 Opened 4 years ago Closed 3 years ago

Selected area in timeline goes insane when I toggle Devtools docking mode

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect, P1)

defect

Tracking

(firefox45 unaffected, firefox46 unaffected, firefox47- wontfix, firefox48 verified, firefox49 verified, firefox50 verified)

VERIFIED FIXED
Firefox 50
Tracking Status
firefox45 --- unaffected
firefox46 --- unaffected
firefox47 - wontfix
firefox48 --- verified
firefox49 --- verified
firefox50 --- verified

People

(Reporter: arni2033, Assigned: gregtatum)

References

Details

(Keywords: regression, Whiteboard: [btpp-fix-later])

Attachments

(1 file)

>>>   My Info:   Win7_64, Nightly 48, 32bit, ID 20160330030326
STR:
0. Open devtools, dock it to the right side of window, dock it to the bottom side of window, close devtools.
1. Open Devtools -> Performance
2. Press button "Start Recording Performance". Press it again to end recording.
3. Click  "JS Flame Chart"  tab to switch to it.
4. Press Ctrl+Shift+D
5. Click  "Waterfall"  tab to switch to it.
6. Press Ctrl+Shift+D
7. Click  "JS Flame Chart"  tab to switch to it.

Result:        After Step 7 selected area in timeline quickly collapses at the end of timeline
Expectations:  Selected area in timeline should stay still
Woo! That one is fun.
Priority: -- → P2
Whiteboard: [btpp-fix-later]
Platform triage decision: This is not something that we will block Fx47 release on.
[Triage] Patrick: can you comment on severity here? Thx.
Flags: needinfo?(pbrosset)
I'll let Greg comment on this one as he knows more about the performance tool (or who to talk to about it), than me.
Flags: needinfo?(pbrosset) → needinfo?(gtatum)
This only happens when you hit the cmd+d shortcut on that specific view, so the severity seems medium to me. Although I believe it could be a quick fix since you just need to account for the modifiers being used on the shortcuts. It might be worth tackling.
Flags: needinfo?(gtatum)
Assignee: nobody → gtatum
Priority: P2 → P1
I made the Flame Graph ignore keys with any modifiers and it cleared up the issue.
Attachment #8771980 - Flags: review?(jsantell)
Comment on attachment 8771980 [details] [diff] [review]
Fix shortcut modifier bug with Flame Graph.

Review of attachment 8771980 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!
Attachment #8771980 - Flags: review?(jsantell) → review+
Keywords: checkin-needed
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/46d964768cf6
Fix shortcut modifier bug with Flame Graph. r=jsantell
Keywords: checkin-needed
Looks like a simple enough change that could be uplifted to aurora and beta in time for the 48 release.
Once this lands on m-c, could you please request uplift approvals?
https://hg.mozilla.org/mozilla-central/rev/46d964768cf6
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
Comment on attachment 8771980 [details] [diff] [review]
Fix shortcut modifier bug with Flame Graph.

Approval Request Comment
[Feature/regressing bug #]: 1261048
[User impact if declined]: The performance tool can break and the graph will begin to act erratic on hitting certain shortcut combinations.

[Describe test coverage new/current, TreeHerder]: The flame graph has mochitest coverage for the individual features of the graph here: https://dxr.mozilla.org/mozilla-central/search?q=path%3Adevtools%2Fclient%2Fshared%2Ftest+path%3Aflame&redirect=false and overall integration coverage here: https://dxr.mozilla.org/mozilla-central/search?q=path%3Adevtools%2Fclient%2Fperformance+path%3Aflame&redirect=false

[Risks and why]: This is low risk as it adds a small modifier button check to a handler.

[String/UUID change made/needed]: None.
Attachment #8771980 - Flags: approval-mozilla-beta?
Attachment #8771980 - Flags: approval-mozilla-aurora?
Comment on attachment 8771980 [details] [diff] [review]
Fix shortcut modifier bug with Flame Graph.

Review of attachment 8771980 [details] [diff] [review]:
-----------------------------------------------------------------

We'll have 48 beta 10 to mitigate the potential regression. This patch fixes a shortcut regression with Flame Graph. Let's take it in 48 beta 10 and aurora. This also needs to be verified.
Attachment #8771980 - Flags: approval-mozilla-beta?
Attachment #8771980 - Flags: approval-mozilla-beta+
Attachment #8771980 - Flags: approval-mozilla-aurora?
Attachment #8771980 - Flags: approval-mozilla-aurora+
Flags: qe-verify+
I managed to reproduce this issue on Firefox 48.0a1 (2016-03-30) and on Windows 10 x64, using STR from Comment 0.
The issue is no longer reproducible on Firefox 48.0b10, Firefox 49.0a2 (2016-07-22), Firefox 50.0a1 (2016-07-21).
The tests were performed on Windows 10 x64, Ubuntu 16.04 x64 and on Mac OS X 10.11.1
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.